merge of '2b1cc78c259b50ef47b34d85e4f6717f64d1d093'
[openembedded.git] / packages / linux / linux-rp_2.6.20.bb
1 require linux-rp.inc
2
3 PR = "r18"
4
5 # Handy URLs
6 # git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;tag=ef7d1b244fa6c94fb76d5f787b8629df64ea4046
7 # http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2
8 # http://www.kernel.org/pub/linux/kernel/v2.6/testing/linux-2.6.20-rc4.tar.bz2
9 # http://www.kernel.org/pub/linux/kernel/v2.6/testing/patch-2.6.18-rc6.bz2;patch=1
10 # http://www.kernel.org/pub/linux/kernel/v2.6/snapshots/patch-2.6.18-rc2-git1.bz2;patch=1
11 # http://www.kernel.org/pub/linux/kernel/people/alan/linux-2.6/2.6.10/patch-2.6.10-ac8.gz;patch=1
12 # http://www.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.14-rc2/2.6.14-rc2-mm1/2.6.14-rc2-mm1.bz2;patch=1
13
14 # Patches submitted upstream are towards top of this list 
15 # Hacks should clearly named and at the bottom
16 SRC_URI = "http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.20.tar.bz2 \
17            http://www.kernel.org/pub/linux/kernel/v2.6/patch-2.6.20.6.bz2;patch=1 \
18            http://opensource.wolfsonmicro.com/~lg/asoc/asoc-v0.13.3.patch;patch=1;status=merged \
19            ${RPSRC}/oprofile_always_bt_arm-r0.patch;patch=1 \
20            ${RPSRC}/lzo_kernel-r0.patch;patch=1 \
21            ${RPSRC}/lzo_jffs2-r0.patch;patch=1 \
22            ${RPSRC}/lzo_crypto-r0a.patch;patch=1 \
23            ${RPSRC}/lzo_jffs2_lzomode-r0.patch;patch=1 \
24            ${RPSRC}/lzo_jffs2_sysfs-r0.patch;patch=1 \
25            ${RPSRC}/hx2750_base-r28.patch;patch=1 \
26            ${RPSRC}/hx2750_bl-r8.patch;patch=1 \
27            ${RPSRC}/hx2750_pcmcia-r2.patch;patch=1 \
28            ${RPSRC}/pxa_keys-r7.patch;patch=1 \
29            ${RPSRC}/tsc2101-r16.patch;patch=1 \
30            ${RPSRC}/hx2750_test1-r6.patch;patch=1 \
31            ${RPSRC}/pxa_timerfix-r0.patch;patch=1 \
32            ${RPSRC}/input_power-r6.patch;patch=1 \
33            ${RPSRC}/pxa25x_cpufreq-r2.patch;patch=1 \
34            ${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
35            ${RPSRC}/pm_changes-r1.patch;patch=1 \
36            ${RPSRC}/usb_add_epalloc-r3.patch;patch=1 \
37            ${RPSRC}/usb_pxa27x_udc-r3.patch;patch=1 \
38            ${RPSRC}/kexec-arm-r4a.patch;patch=1 \
39            ${RPSRC}/locomo_kbd_tweak-r1.patch;patch=1 \
40            ${RPSRC}/poodle_pm-r3.patch;patch=1 \
41            ${RPSRC}/pxa27x_overlay-r5.patch;patch=1 \
42            ${RPSRC}/w100_extaccel-r0.patch;patch=1 \
43            ${RPSRC}/w100_extmem-r0.patch;patch=1 \
44            file://hostap-monitor-mode.patch;patch=1 \
45            file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1 \
46            ${RPSRC}/logo_oh-r0.patch.bz2;patch=1;status=unmergable \
47            ${RPSRC}/logo_oz-r2.patch.bz2;patch=1;status=unmergable \
48            ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable \
49            ${RPSRC}/mmcsd_large_cards-r0.patch;patch=1;status=hack \
50            ${RPSRC}/mmcsd_no_scr_check-r0.patch;patch=1;status=hack \
51            ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack \
52            ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack \
53            file://pxa-serial-hack.patch;patch=1;status=hack \
54            file://connectplus-remove-ide-HACK.patch;patch=1;status=hack \
55            file://squashfs3.0-2.6.15.patch;patch=1;status=external \
56            file://vesafb-tng-1.0-rc2-2.6.20-rc2.patch;patch=1;status=external \
57            file://sharpsl-rc-r1.patch;patch=1 \
58            file://defconfig-c7x0 \
59            file://defconfig-hx2000 \
60            file://defconfig-collie \
61            file://defconfig-poodle \
62            file://defconfig-akita \
63            file://defconfig-spitz* \
64            file://defconfig-qemuarm \
65            file://defconfig-qemux86 \
66            file://defconfig-tosa "
67
68 # Add this to enable pm debug code (useful with a serial lead)
69 #  ${RPSRC}/sharpsl_pm_debug-r0.patch;patch=1
70
71 # Disabled until I find the reason this gives issues with cdc_subset
72 #            ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1 \
73
74 # Is anything out of this still needed? Parts were commited to mainline by rmk (drivers/mfd/)
75 # (Pavel Machek's git tree has updated versions of this?)
76 #  ${JLSRC}/zaurus-lcd-2.6.11.diff.gz;patch=1
77
78 # These patches are extracted from Pavel Machek's git tree
79 # (diff against vanilla kernel)
80
81 SRC_URI_append_collie = "\
82            ${TKSRC}/mtd-sharp-flash-hack-r2.patch;patch=1 \
83            ${TKSRC}/ucb1x00-touch-audio-r1.patch;patch=1 \
84            ${TKSRC}/mcp-sa11x0-r0.patch;patch=1 \
85            ${TKSRC}/sa1100-udc-r2.patch;patch=1 \
86            ${TKSRC}/mmc_spi-r4.patch;patch=1 \
87            ${TKSRC}/locomo-r0.patch;patch=1 \
88            ${TKSRC}/collie-kexec.patch;patch=1 \
89            ${TKSRC}/locomo_spi-r3.patch;patch=1 \
90            ${TKSRC}/sharpsl_pm.patch;patch=1 \
91            ${TKSRC}/collie_pm-2.patch;patch=1 \
92            ${TKSRC}/locomokeyb_suspendkey.patch;patch=1 \
93            ${TKSRC}/pcmcia_suspend.patch;patch=1 \
94            ${TKSRC}/ucb1x00_suspend.patch;patch=1 \
95 "
96
97 SRC_URI_append_tosa = "\
98            ${CHSRC}/usb-ohci-hooks-r1.patch;patch=1 \
99            ${CHSRC}/tmio-core-r4.patch;patch=1 \
100            file://tmio-tc6393-r8.patch;patch=1 \
101            file://tmio-nand-r7.patch;patch=1 \
102            file://tmio-ohci-r6.patch;patch=1 \
103            ${CHSRC}/tmio-fb-r6.patch;patch=1 \
104            file://tosa-keyboard-r18.patch;patch=1 \
105            ${DOSRC}/tosa-pxaac97-r6.patch;patch=1 \
106            ${DOSRC}/tosa-tmio-r6.patch;patch=1 \
107            ${DOSRC}/tosa-power-r17.patch;patch=1 \
108            file://tosa-tmio-lcd-r10.patch;patch=1 \
109            ${DOSRC}/tosa-bluetooth-r8.patch;patch=1 \
110            ${DOSRC}/wm97xx-lg7-r0.patch;patch=1 \
111            file://wm9712-suspend-cold-res-r2.patch;patch=1 \
112            file://sharpsl-pm-postresume-r1.patch;patch=1 \
113            ${DOSRC}/wm97xx-dig-restore-r0.patch;patch=1 \
114            ${DOSRC}/wm97xx-miscdevs-resume-r0.patch;patch=1 \
115            file://wm9712-reset-loop-r2.patch;patch=1 \
116            file://tosa-lcdnoise-r1.patch;patch=1 \
117            file://wm97xx-lcdnoise-r0.patch;patch=1 "
118 #          ${DOSRC}/tosa-asoc-r1.patch;patch=1 "
119
120 S = "${WORKDIR}/linux-2.6.20"