84b35b1e8d438485032cc7f8f583046e6cb776cf
[openembedded.git] / packages / gimp / gimp_2.3.8.bb
1 DESCRIPTION =   "The GIMP is the GNU Image Manipulation Program."
2 HOMEPAGE =      "http://www.gimp.org"
3 LICENSE =       "GPL"
4 MAINTAINER =    "Koen Kooi <koen@handhelds.org>"
5
6 SRC_URI =       "ftp://ftp.gimp.org/pub/gimp/v2.3/gimp-${PV}.tar.bz2 \
7                  file://configure-libwmf.patch;patch=1"
8
9 DEPENDS =       "sed-native libart-lgpl gtk+ jpeg libpng libexif tiff"
10
11 inherit autotools pkgconfig
12 #Don't laugh, this just builds a threaded gimp
13 EXTRA_OECONF =  " --disable-gtktest \
14                 --disable-print \
15                 --disable-python \
16                 --enable-mp \
17                 --without-libwmf"
18
19 do_configure_append() {
20         find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
21 }