lots of files: fix my mailaddress
[openembedded.git] / packages / fuse / fuse-module_2.4.2.bb
1 HOMEPAGE = "http://fuse.sf.net"
2 DESCRIPTION = "With FUSE it is possible to implement a fully functional filesystem in a userspace program"
3 MAINTAINER = "Koen Kooi <koen@linuxtogo.org>"
4
5 LICENSE = "GPL"
6
7
8 DEPENDS = "fakeroot-native"
9 RRECOMMEND = "fuse"
10
11 SRC_URI="${SOURCEFORGE_MIRROR}/fuse/fuse-${PV}.tar.gz"
12 S = "${WORKDIR}/fuse-${PV}"
13
14 inherit autotools pkgconfig module
15 EXTRA_OECONF = "  --with-kernel=${STAGING_KERNEL_DIR}"
16
17 do_configure() {
18 cd ${S} ; oe_runconf
19 }
20
21 do_compile(){
22 LDFLAGS=""
23 cd ${S}/kernel
24 oe_runmake
25 }
26
27 fakeroot do_install() {
28 LDFLAGS=""
29 cd ${S}/kernel
30 oe_runmake install DESTDIR=${D}
31 }
32
33 FILES_${PN} = "/dev /lib/modules"