ftpd-topfield: Updated to 0.7.5 and added the syslog patch
[openembedded.git] / packages / ftpd-topfield / ftpd-topfield_0.7.5.bb
1 # This package builds the ftpd-topfield program
2 DESCRIPTION = "ftpd-topfield - FTP access to TopField PVR"
3 HOMEPAGE = "http://sourceforge.net/projects/puppy"
4 SECTION = "net"
5 LICENSE = "MIT"
6 PR = "r1"
7
8 SRC_URI = "cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=ftpd-topfield;tag=FTPD_TOPFIELD_0_7_5 \
9            cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=libtopfield;tag=FTPD_TOPFIELD_0_7_5 \
10            file://syslog.patch;patch=1 \
11            file://init"
12
13 # The source will end up in the subdirectory 'ftpd-topfield' - no release name
14 S = "${WORKDIR}/ftpd-topfield"
15
16 inherit update-rc.d
17
18 INITSCRIPT_NAME = "ftpd-topfield"
19 INITSCRIPT_PARAMS = "defaults"
20
21 # Just the one package at present
22
23 inherit autotools
24
25 do_compile() {
26         oe_runmake
27 }
28
29 do_install() {
30         install -d ${D}${sbindir}
31         install -m 0755 ${S}/ftpd ${D}${sbindir}/ftpd-topfield
32         install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/init.d
33         install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ftpd-topfield
34 }