7a7291a156cfef38b18b41651324f2e0fe4ce9c8
[openembedded.git] / packages / e17 / e-wm_0.16.999.015.bb
1 DESCRIPTION = "E17 - the Enlightenment Window Mananger"
2 DEPENDS = "evas-x11 ecore-x11 edje eet embryo e"
3 LICENSE = "MIT"
4 SECTION = "e/apps"
5 MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
6 CVSDATE = "${PV}"
7 PR = "r3"
8
9 SRC_URI = "http://enlightenment.freedesktop.org/files/enlightenment-${PV}.tar.gz \
10            file://fix-configure.patch;patch=1 \
11            file://remove-large-fonts.patch;patch=1 \
12            file://disable-splash.patch;patch=1 \
13            file://Xsession.d/98enlightenment \
14            cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/apps/e/data/themes;date=20050926"
15 #           http://cvs.sourceforge.net/viewcvs.py/*checkout*/enlightenment/e17/apps/e/data/themes/default_entry.edc?rev=1.1 \
16 #           http://cvs.sourceforge.net/viewcvs.py/*checkout*/enlightenment/e17/apps/e/data/themes/images/focus.png?rev=1.1 \
17 #           http://cvs.sourceforge.net/viewcvs.py/*checkout*/enlightenment/e17/apps/e/data/themes/images/entry.png?rev=1.1 \
18 #           http://cvs.sourceforge.net/viewcvs.py/*checkout*/enlightenment/e17/apps/e/data/themes/images/entry_focus.png?rev=1.1"
19
20 S = "${WORKDIR}/enlightenment-${PV}"
21
22 inherit autotools
23
24 PROFILE = "LORES_PDA"
25 PROFILE_c7x0 = "HIRES_PDA"
26 PROFILE_tosa = "HIRES_PDA"
27 PROFILE_spitz = "HIRES_PDA"
28 PROFILE_akita = "HIRES_PDA"
29
30 EXTRA_OECONF = "--with-profile=${PROFILE} \
31                 --with-edje-cc=${STAGING_BINDIR}/edje_cc \
32                 --x-includes=${STAGING_INCDIR}/X11 \
33                 --x-libraries=${STAGING_LIBDIR}"
34
35 FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir}"
36
37 do_compile_prepend() {
38         find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
39         mv "${WORKDIR}/themes/default_entry.edc" "${S}/data/themes/"
40         mv "${WORKDIR}/themes/images/focus.png" "${S}/data/themes/images/"
41         mv "${WORKDIR}/themes/images/entry.png" "${S}/data/themes/images/"
42         mv "${WORKDIR}/themes/images/entry_focus.png" "${S}/data/themes/images/"
43 }
44
45 do_install_append() {
46         install -d ${D}/${sysconfdir}/X11/Xsession.d
47         install -m 755 ${WORKDIR}/Xsession.d/98enlightenment ${D}/${sysconfdir}/X11/Xsession.d
48 }