Enabled INPUT and USB_HID modules in the OpenSlug kernel
[openembedded.git] / packages / curl / curl_7.14.0.bb
1 # NOTE: FIXME: curl puts its LDFLAGS in its curl-config and curl.pc files.
2 # This is flawed, as the LDFLAGS are often overridden by the user, and in
3 # addition, are generally specific to the *build* environment, not target.
4 # curl's build should be fixed to manipulate LIBS where appropriate and
5 # use that. -CL
6
7 DESCRIPTION = "Command line tool and library for \
8 client-side URL transfers."
9 LICENSE = "MIT" 
10 DEPENDS = "zlib"
11 SECTION = "console/network"
12 PR = "r0"
13
14 SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2"
15
16 inherit autotools pkgconfig
17
18 EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
19                 --without-ssl --with-random=/dev/urandom"
20
21 do_stage () {
22         install -d ${STAGING_INCDIR}/curl
23         install -m 0644 ${S}/include/curl/*.h ${STAGING_INCDIR}/curl/
24         oe_libinstall -so -a -C lib libcurl ${STAGING_LIBDIR}
25
26         cat curl-config | sed -e "s,-I/usr/include,-I${STAGING_INCDIR}/," \
27                         | sed -e "s,-L/usr/lib , , "> ${STAGING_BINDIR}/curl-config
28         chmod a+rx ${STAGING_BINDIR}/curl-config
29 }
30
31 PACKAGES = "curl curl-doc libcurl libcurl-dev libcurl-doc"
32 FILES_${PN} = "${bindir}/curl"
33 FILES_${PN}-doc = "${mandir}/man1/curl.1"
34 FILES_lib${PN} = "${libdir}/lib*.so.*"
35 FILES_lib${PN}-dev = "${includedir} \
36                       ${libdir}/lib*.so \
37                       ${libdir}/lib*.a \
38                       ${libdir}/lib*.la \
39                       ${libdir}/pkgconfig \
40                       ${datadir}/aclocal \
41                       ${bindir}/*-config"
42 FILES_lib${PN}-doc = "${mandir}/man3 \
43                       ${mandir}/man1/curl-config.1"
44