xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / classes / scons.bbclass
1 DEPENDS += "python-scons-native"
2
3 export TARGET_LINK_HASH_STYLE
4
5 scons_do_compile() {
6     if [ "${SCONS_FIX_ENV}" = "1" ] ; then
7         if grep "toolchain-from-env" ${S}/SConstruct ; then
8             echo "Toolchain overrides already applied"
9         else
10            cat ${STAGING_DATADIR_NATIVE}/scons/toolchain-from-env.SConscript >> ${S}/SConstruct
11         fi
12     fi
13
14     ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} CXX="${CXX}" PREFIX=${prefix} prefix=${prefix} || \
15     oefatal "scons build execution failed."
16 }
17
18 scons_do_install() {
19         install -d ${D}${prefix}
20         ${STAGING_BINDIR_NATIVE}/scons PREFIX=${D}${prefix} prefix=${D}${prefix} install || \
21         oefatal "scons install execution failed."
22 }
23
24 EXPORT_FUNCTIONS do_compile do_install