merge of '3a4c124aa9688e101e4d5547ad18d4512d45e47b'
[openembedded.git] / classes / sanity.bbclass
1 #
2 # Sanity check the users setup for common misconfigurations
3 #
4
5 def raise_sanity_error(msg):
6         import bb
7         bb.fatal(""" Openembedded's config sanity checker detected a potential misconfiguration.
8         Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
9         Following is the list of potential problems / advisories:
10         
11         %s""" % msg)
12
13 def check_conf_exists(fn, data):
14         import bb, os
15
16         bbpath = []
17         fn = bb.data.expand(fn, data)
18         vbbpath = bb.data.getVar("BBPATH", data)
19         if vbbpath:
20                 bbpath += vbbpath.split(":")
21         for p in bbpath:
22                 currname = os.path.join(bb.data.expand(p, data), fn)
23                 if os.access(currname, os.R_OK):
24                         return True
25         return False
26
27 def check_app_exists(app, d):
28         from bb import which, data
29
30         app = data.expand(app, d)
31         path = data.getVar('PATH', d)
32         return len(which(path, app)) != 0
33
34
35 def check_sanity(e):
36         from bb import note, error, data, __version__
37         from bb.event import Handled, NotHandled, getName
38         try:
39                 from distutils.version import LooseVersion
40         except ImportError:
41                 def LooseVersion(v): print "WARNING: sanity.bbclass can't compare versions without python-distutils"; return 1
42         import os
43
44         # Check the bitbake version meets minimum requirements
45         minversion = data.getVar('BB_MIN_VERSION', e.data , True)
46         if not minversion:
47                 # Hack: BB_MIN_VERSION hasn't been parsed yet so return 
48                 # and wait for the next call
49                 print "Foo %s" % minversion
50                 return
51
52         messages = ""
53
54         if (LooseVersion(__version__) < LooseVersion(minversion)):
55                 messages = messages + 'Bitbake version %s is required and version %s was found\n' % (minversion, __version__)
56
57         # Check TARGET_ARCH is set
58         if data.getVar('TARGET_ARCH', e.data, True) == 'INVALID':
59                 messages = messages + 'Please set TARGET_ARCH directly, or choose a MACHINE or DISTRO that does so.\n'
60         
61         # Check TARGET_OS is set
62         if data.getVar('TARGET_OS', e.data, True) == 'INVALID':
63                 messages = messages + 'Please set TARGET_OS directly, or choose a MACHINE or DISTRO that does so.\n'
64
65         # Check user doesn't have ASSUME_PROVIDED = instead of += in local.conf
66         if "diffstat-native" not in data.getVar('ASSUME_PROVIDED', e.data, True).split():
67                 messages = messages + 'Please use ASSUME_PROVIDED +=, not ASSUME_PROVIDED = in your local.conf\n'
68         
69         # Check that the MACHINE is valid
70         if not check_conf_exists("conf/machine/${MACHINE}.conf", e.data):
71                 messages = messages + 'Please set a valid MACHINE in your local.conf\n'
72         
73         # Check that the DISTRO is valid
74         # need to take into account DISTRO renaming DISTRO
75         if not ( check_conf_exists("conf/distro/${DISTRO}.conf", e.data) or check_conf_exists("conf/distro/include/${DISTRO}.inc", e.data) ):
76                 messages = messages + "DISTRO '%s' not found. Please set a valid DISTRO in your local.conf\n" % data.getVar("DISTRO", e.data, True )
77
78         missing = ""
79
80         if not check_app_exists("${MAKE}", e.data):
81                 missing = missing + "GNU make,"
82
83         if not check_app_exists('${BUILD_PREFIX}gcc', e.data):
84                 missing = missing + "C Compiler (${BUILD_PREFIX}gcc),"
85
86         if not check_app_exists('${BUILD_PREFIX}g++', e.data):
87                 missing = missing + "C++ Compiler (${BUILD_PREFIX}g++),"
88
89         required_utilities = "patch diffstat texi2html makeinfo cvs svn git bzip2 tar gzip gawk"
90
91         for util in required_utilities.split():
92                 if not check_app_exists( util, e.data ):
93                         missing = missing + "%s," % util
94
95         if missing != "":
96                 missing = missing.rstrip(',')
97                 messages = messages + "Please install following missing utilities: %s\n" % missing
98
99         oes_bb_conf = data.getVar( 'OES_BITBAKE_CONF', e.data, True )
100         if not oes_bb_conf:
101                 messages = messages + 'You do not include OpenEmbeddeds version of conf/bitbake.conf\n'
102
103         if messages != "":
104                 raise_sanity_error(messages)
105
106 addhandler check_sanity_eventhandler
107 python check_sanity_eventhandler() {
108     from bb import note, error, data, __version__
109     from bb.event import getName
110
111     if getName(e) == "BuildStarted":
112         check_sanity(e)
113
114     return NotHandled
115 }