1 inherit autotools pkgconfig
3 HOMEPAGE = "http://www.openmoko.org"
4 OPENMOKO_RELEASE ?= "OM-2007.2"
5 OPENMOKO_MIRROR ?= "svn://svn.openmoko.org/trunk"
7 def openmoko_two_get_license(d):
9 openmoko, section = bb.data.getVar('SECTION', d, 1).split("/")
10 return "LGPL GPL".split()[section != "libs"]
12 def openmoko_two_get_subdir(d):
14 openmoko, section = bb.data.getVar('SECTION', d, 1).split("/")
15 if section == 'base': return ""
16 elif section == 'libs': return "libraries"
17 elif section in 'apps tools pim'.split(): return "applications"
18 elif section == "panel-plugin": return "panel-plugins"
19 elif section == "inputmethods": return "inputmethods"
20 elif section == "daemons": return "daemons"
21 elif section == "misc": return "misc"
24 LICENSE = "${@openmoko_two_get_license(d)}"
25 SUBDIR = "${@openmoko_two_get_subdir(d)}"
27 SRC_URI := "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE}/${SUBDIR};module=${PN};proto=http"
28 S = "${WORKDIR}/${PN}"
30 FILES_${PN} += "${datadir}/icons"
33 #SVNREV = "${SRCDATE}"