import clean BK tree at cset 1.3670
[openembedded.git] / classes / gpe.bbclass
1 DEPENDS_prepend = "coreutils-native virtual/libintl intltool-native "
2 SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.gz"
3 FILES_${PN} += "${datadir}/gpe ${datadir}/application-registry"
4
5 inherit gettext
6
7 gpe_do_compile() {
8         oe_runmake PREFIX=${prefix}
9 }
10
11 gpe_do_install() {
12         oe_runmake PREFIX=${prefix} DESTDIR=${D} install
13 }
14
15 EXPORT_FUNCTIONS do_compile do_install