merge of 21d66a92293faf76a506c7d17e3cd16e143bb401
[openembedded.git] / classes / gpe.bbclass
1 DEPENDS_prepend = "coreutils-native virtual/libintl intltool-native "
2 GPE_TARBALL_SUFFIX ?= "gz"
3 SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.${GPE_TARBALL_SUFFIX}"
4 FILES_${PN} += "${datadir}/gpe ${datadir}/application-registry"
5
6 inherit gettext
7
8 gpe_do_compile() {
9         oe_runmake PREFIX=${prefix}
10 }
11
12 gpe_do_install() {
13         oe_runmake PREFIX=${prefix} DESTDIR=${D} install
14 }
15
16 EXPORT_FUNCTIONS do_compile do_install