irssi: add 0.8.13
authorKoen Kooi <koen@openembedded.org>
Mon, 8 Jun 2009 21:09:32 +0000 (23:09 +0200)
committerKoen Kooi <koen@openembedded.org>
Mon, 8 Jun 2009 21:09:32 +0000 (23:09 +0200)
* this one actually builds with a recent toolchain and userspace

conf/checksums.ini
recipes/irssi/irssi_0.8.13.bb [new file with mode: 0644]

index c3c83c3..d6f697a 100644 (file)
@@ -11286,6 +11286,10 @@ sha256=47344b444d78ad5965eb40cc4c8df8450fdc54135e2b058710ee8c500b958d6c
 md5=e407b557b3cfc7c91ce4de2571dd79cb
 sha256=462d634bb509cc2bdd550ee5c7b269495f3173721b7404f162ad1f69b49bfff0
 
+[http://www.irssi.org/files/irssi-0.8.13.tar.bz2]
+md5=0d6fc2203832b514eff014fffd574664
+sha256=896541ac837421290934e2658ab364d4d3f0326259489a94a0cd166e2b05d735
+
 [http://heanet.dl.sourceforge.net/iscsitarget/iscsitarget-0.4.16.tar.gz]
 md5=c7ea3192f1717b40e4c483c9d630082d
 sha256=e6605ae5f9ed2e2fdbe84df967236678579a4fbe536b75a93277cbb607bead7d
diff --git a/recipes/irssi/irssi_0.8.13.bb b/recipes/irssi/irssi_0.8.13.bb
new file mode 100644 (file)
index 0000000..9091ddc
--- /dev/null
@@ -0,0 +1,61 @@
+DESCRIPTION = "Irssi is a modular IRC client with Perl scripting."
+HOMEPAGE = "http://irssi.org/"
+SECTION = "console/network"
+LICENSE = "GPL"
+DEPENDS += "ncurses glib-2.0"
+
+PACKAGES += "${PN}-common"
+FILES_${PN} = "${bindir}/irssi"
+FILES_${PN}-common = "${datadir}/irssi ${sysconfdir}"
+RDEPENDS_${PN} += "${PN}-common"
+
+inherit autotools
+
+SRC_URI = "http://www.irssi.org/files/${P}.tar.bz2 \
+"
+
+EXTRA_OECONF = "--enable-ipv6 \
+               --disable-ssl \
+               --disable-glibtest \
+               --without-socks \
+               --with-textui \
+               --without-bot \
+               --without-proxy \
+               --with-perl=no \
+               --with-ncurses=${STAGING_LIBDIR}/.."
+
+do_configure () {
+       # create help files
+       echo "Creating help files..."
+       perl syntax.pl
+
+       files=`echo docs/help/in/*.in|sed -e 's,docs/help/in/Makefile.in ,,' -e 's,docs/help/in/,!,g' -e 's/\.in /.in ?/g'`
+       cat docs/help/in/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/in/Makefile.am
+
+       files=`echo $files|sed 's/\.in//g'`
+       cat docs/help/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/Makefile.am
+
+       # .HTML -> .txt with lynx
+       # echo "Documentation: html -> txt..."
+       # lynx -dump -nolist docs/faq.html|perl -pe 's/^ *//; if ($_ eq "\n" && $state eq "Q") { $_ = ""; } elsif (/^([QA]):/) { $state = $1 } elsif ($_ ne "\n") { $_ = "   $_"; };' > docs/faq.txt
+       > docs/faq.txt
+
+       autotools_do_configure
+}
+
+do_stage () {
+       find . -name \*.h | for h in `cat`; do
+               install -d ${STAGING_LIBDIR}/../irssi/`dirname $h`
+               install -m 0644 $h ${STAGING_LIBDIR}/../irssi/$h
+       done
+       find . -name lib\*.a | for l in `cat`; do
+               install -d ${STAGING_LIBDIR}/../irssi/`dirname $l`
+               install -m 0644 $l ${STAGING_LIBDIR}/../irssi/$l
+       done
+       install -m 0644 irssi-config ${STAGING_LIBDIR}/../irssi/
+}
+
+do_install () {
+       autotools_do_install
+       rm -f ${D}${docdir}/irssi/faq.txt
+}