classpath-native: update the ecj-patch
authorHenning Heinold <heinold@inf.fu-berlin.de>
Thu, 24 Jun 2010 19:34:40 +0000 (21:34 +0200)
committerHenning Heinold <heinold@inf.fu-berlin.de>
Thu, 24 Jun 2010 19:36:17 +0000 (21:36 +0200)
* the java-files in tools aren't UTF8 at all
  so we need the same handling as with asm-files
* bump PR

recipes/classpath/classpath-native_0.98.bb
recipes/classpath/files/ecj_java_dir.patch

index a8d8276..9e2654b 100644 (file)
@@ -3,7 +3,7 @@ require classpath-native.inc
 # Deadlocks occur on at least amd64 hosts.
 DEFAULT_PREFERENCE = "-1"
 
-PR = "r3"
+PR = "r4"
 
 # The code affected by the javanet-local patch
 # is usually not compiled. However if someone changes
index e310567..1455a24 100644 (file)
@@ -1,34 +1,37 @@
-Index: classpath-0.97.2/lib/gen-classlist.sh.in
+Index: classpath-0.98/lib/gen-classlist.sh.in
 ===================================================================
---- classpath-0.97.2.orig/lib/gen-classlist.sh.in      2008-06-02 03:37:29.000000000 +0200
-+++ classpath-0.97.2/lib/gen-classlist.sh.in   2008-08-01 00:00:58.055208770 +0200
+--- classpath-0.98.orig/lib/gen-classlist.sh.in        2010-06-24 21:18:02.776819217 +0200
++++ classpath-0.98/lib/gen-classlist.sh.in     2010-06-24 21:18:35.625566191 +0200
 @@ -148,4 +148,7 @@
    done
  fi
  
 +# hack for javac that uses -d and do not make the directories
-+awk -F " " '{print $1}' classes.1 | uniq | awk -F " " '{system("mkdir -p " $0)}'
++@AWK@ -F " " '{print $1}' classes.1 | uniq | awk -F " " '{system("mkdir -p " $0)}'
 +
  exit 0
-Index: classpath-0.97.2/tools/Makefile.am
+Index: classpath-0.98/tools/Makefile.am
 ===================================================================
---- classpath-0.97.2.orig/tools/Makefile.am    2008-06-02 04:01:47.000000000 +0200
-+++ classpath-0.97.2/tools/Makefile.am 2008-08-01 00:11:18.531985989 +0200
-@@ -180,6 +180,8 @@
-       mkdir classes asm
+--- classpath-0.98.orig/tools/Makefile.am      2010-06-24 21:18:02.783479881 +0200
++++ classpath-0.98/tools/Makefile.am   2010-06-24 21:20:04.925557253 +0200
+@@ -323,6 +323,8 @@
+ endif
  ## Compile ASM separately as it is latin-1 encoded.
        find $(srcdir)/external/asm -name '*.java' -print > asm.lst
-+      awk -F "/" '{OFS=FS;gsub("/"$$2"/"$$3,"",$$0);gsub("/"$$NF,"",$$0); print $$0}' asm.lst | \
-+         sort | uniq | awk -F " " '{system("mkdir -p asm/" $$0)}'
++      @AWK@ -F "/" '{OFS=FS;gsub("/"$$2"/"$$3,"",$$0);gsub("/"$$NF,"",$$0); print $$0}' asm.lst | \
++         sort | uniq | @AWK@ -F " " '{system("mkdir -p asm/" $$0)}'
        AC=`echo $(JCOMPILER) | sed -e 's/UTF-8/ISO-8859-1/g'`; \
          $$AC -g -d asm @asm.lst
        find $(srcdir)/gnu/classpath/tools \
-@@ -189,6 +191,8 @@
-            $(srcdir)/com/sun/tools/javah \
+@@ -334,7 +336,10 @@
             $(srcdir)/sun/rmi/rmic \
+            $(GJDOC_EX) \
             -name '*.java' -print > classes.lst
-+      awk -F "/" '{OFS=FS;gsub("/"$$NF,"",$$0); print $$0}' classes.lst | \
-+           sort | uniq | awk -F " " '{system("mkdir -p classes/" $$0)}'
-       $(JCOMPILER) -g -d classes @classes.lst
+-      $(JCOMPILER) -g -d classes @classes.lst
++      @AWK@ -F "/" '{OFS=FS;gsub("/"$$NF,"",$$0); print $$0}' classes.lst | \
++           sort | uniq | @AWK@ -F " " '{system("mkdir -p classes/" $$0)}'
++      BC=`echo $(JCOMPILER) | sed -e 's/UTF-8/ISO-8859-1/g'`; \
++         $$BC -g -d classes @classes.lst
        cat classes.lst asm.lst > all-classes.lst
  ## Copy over tools resource files.
+       @list=`cd $(srcdir)/resource && find gnu/classpath/tools com/sun/tools/javac \