conf: Decosmetize TARGET_OS
authorKhem Raj <raj.khem@gmail.com>
Thu, 8 Oct 2009 23:03:58 +0000 (16:03 -0700)
committerKhem Raj <raj.khem@gmail.com>
Sat, 10 Oct 2009 07:58:56 +0000 (00:58 -0700)
* This patch reverts the cosmetic change which used linux-gnu instead of linux

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Tested-by: Holger Freyther <zecke@selfish.org>
14 files changed:
classes/insane.bbclass
classes/siteinfo.bbclass
conf/distro/include/angstrom-eglibc.inc
conf/distro/include/angstrom-glibc.inc
conf/distro/include/sane-toolchain.inc
recipes/lsof/lsof_4.78.bb
recipes/openssl/openssl.inc
site/arm-linux [moved from site/arm-linux-gnu with 100% similarity]
site/armeb-linux [moved from site/armeb-linux-gnu with 100% similarity]
site/mips-linux [moved from site/mips-linux-gnu with 100% similarity]
site/mipsel-linux [moved from site/mipsel-linux-gnu with 100% similarity]
site/powerpc-linux [moved from site/powerpc-linux-gnu with 100% similarity]
site/sparc-linux [moved from site/sparc-linux-gnu with 100% similarity]
site/x86_64-linux [moved from site/x86_64-linux-gnu with 100% similarity]

index a6e4b6d..0dacaf8 100644 (file)
@@ -34,7 +34,7 @@ def package_qa_get_machine_dict():
             "darwin9" : { 
                         "arm" :       (40,     0,    0,          True,          True),
                       },
-            "linux-gnu" : { 
+            "linux" : { 
                         "arm" :       (40,    97,    0,          True,          True),
                         "armeb":      (40,    97,    0,          False,         True),
                         "powerpc":    (20,     0,    0,          False,         True),
@@ -77,7 +77,7 @@ def package_qa_get_machine_dict():
                         "arm" :       (40,     0,    0,          True,          True),
                         "armeb" :     (40,     0,    0,          False,         True),
                       },
-            "linux-gnuspe" : {
+            "linux-spe" : {
                         "powerpc":    (20,     0,    0,          False,         True),
                       },
             "linux-uclibcspe" : {
index c3e155b..c89014a 100644 (file)
@@ -22,23 +22,21 @@ def get_siteinfo_list(d):
 
        targetinfo = {\
                "armeb-linux":             "endian-big bit-32 common-linux common-glibc arm-common",\
-               "armeb-linux-gnu":         "endian-big bit-32 common-linux common-glibc arm-common",\
-               "armeb-linux-gnueabi":     "endian-big bit-32 common-linux common-glibc arm-common armeb-linux-gnu",\
+               "armeb-linux-gnueabi":     "endian-big bit-32 common-linux common-glibc arm-common armeb-linux",\
                "armeb-linux-uclibc":      "endian-big bit-32 common-linux common-uclibc arm-common",\
                "armeb-linux-uclibceabi":  "endian-big bit-32 common-linux common-uclibc arm-common armeb-linux-uclibc",\
                "arm-darwin":              "endian-little bit-32 common-darwin",\
                "arm-darwin9":             "endian-little bit-32 common-darwin",\
-               "arm-linux-gnu":           "endian-little bit-32 common-linux common-glibc arm-common",\
-               "arm-linux-gnueabi":       "endian-little bit-32 common-linux common-glibc arm-common arm-linux-gnu",\
+               "arm-linux":               "endian-little bit-32 common-linux common-glibc arm-common",\
+               "arm-linux-gnueabi":       "endian-little bit-32 common-linux common-glibc arm-common arm-linux",\
                "arm-linux-uclibc":        "endian-little bit-32 common-linux common-uclibc arm-common",\
                "arm-linux-uclibceabi":    "endian-little bit-32 common-linux common-uclibc arm-common arm-linux-uclibc",\
                "avr32-linux-uclibc":      "endian-big bit-32 common-linux common-uclibc avr32-common",\
                "bfin-uclinux-uclibc":     "endian-little bit-32 common-uclibc bfin-common",\
-               "i386-linux-gnu":          "endian-little bit-32 common-linux common-glibc ix86-common",\
-               "i486-linux-gnu":          "endian-little bit-32 common-linux common-glibc ix86-common",\
-               "i586-linux-gnu":          "endian-little bit-32 common-linux common-glibc ix86-common",\
-               "i686-linux-gnu":          "endian-little bit-32 common-linux common-glibc ix86-common",\
-               "i686-linux":              "endian-little bit-32 common-linux common-glibc ix86-common i686-linux-gnu",\
+               "i386-linux":          "endian-little bit-32 common-linux common-glibc ix86-common",\
+               "i486-linux":          "endian-little bit-32 common-linux common-glibc ix86-common",\
+               "i586-linux":          "endian-little bit-32 common-linux common-glibc ix86-common",\
+               "i686-linux":          "endian-little bit-32 common-linux common-glibc ix86-common",\
                "i386-linux-uclibc":       "endian-little bit-32 common-linux common-uclibc ix86-common",\
                "i486-linux-uclibc":       "endian-little bit-32 common-linux common-uclibc ix86-common",\
                "i586-linux-uclibc":       "endian-little bit-32 common-linux common-uclibc ix86-common",\
@@ -51,24 +49,23 @@ def get_siteinfo_list(d):
                "i486-mingw32":            "endian-little bit-32 common-mingw ix86-common",\
                "i586-mingw32":            "endian-little bit-32 common-mingw ix86-common",\
                "i686-mingw32":            "endian-little bit-32 common-mingw ix86-common",\
-              "ia64-linux-gnu":          "endian-little bit-64 common-linux common-glibc",\
-               "mipsel-linux-gnu":        "endian-little bit-32 common-linux common-glibc mips-common",\
+              "ia64-linux":              "endian-little bit-64 common-linux common-glibc",\
+               "mipsel-linux":            "endian-little bit-32 common-linux common-glibc mips-common",\
                "mipsel-linux-uclibc":     "endian-little bit-32 common-linux common-uclibc mips-common",\
-               "mips-linux-gnu":          "endian-big bit-32 common-linux common-glibc mips-common",\
+               "mips-linux":              "endian-big bit-32 common-linux common-glibc mips-common",\
                "mips-linux-uclibc":       "endian-big bit-32 common-linux common-uclibc mips-common",\
                "powerpc-darwin":          "endian-big bit-32 common-darwin",\
-               "ppc-linux-gnu":           "endian-big bit-32 common-linux common-glibc powerpc-common powerpc-linux-gnu",\
-               "ppc64-linux-gnu":         "endian-big bit-64 common-linux common-glibc powerpc-common powerpc64-linux-gnu",\
-              "powerpc-linux-gnu":       "endian-big bit-32 common-linux common-glibc powerpc-common",\
-              "powerpc-linux-gnuspe":    "endian-big bit-32 common-linux common-glibc powerpc-common powerpc-linux-gnu",\
+               "ppc-linux":               "endian-big bit-32 common-linux common-glibc powerpc-common powerpc-linux",\
+               "ppc64-linux":             "endian-big bit-64 common-linux common-glibc powerpc-common powerpc64-linux",\
+              "powerpc-linux":           "endian-big bit-32 common-linux common-glibc powerpc-common",\
+              "powerpc-linux-spe":       "endian-big bit-32 common-linux common-glibc powerpc-common powerpc-linux",\
                "powerpc-linux-uclibc":    "endian-big bit-32 common-linux common-uclibc powerpc-common",\
                "powerpc-linux-uclibcspe": "endian-big bit-32 common-linux common-uclibc powerpc-common powerpc-linux-uclibc",\
-               "sh3-linux-gnu":           "endian-little bit-32 common-linux common-glibc sh-common",\
-               "sh4-linux-gnu":           "endian-little bit-32 common-linux common-glibc sh-common",\
+               "sh3-linux":               "endian-little bit-32 common-linux common-glibc sh-common",\
+               "sh4-linux":               "endian-little bit-32 common-linux common-glibc sh-common",\
                "sh4-linux-uclibc":        "endian-little bit-32 common-linux common-uclibc sh-common",\
-               "sparc-linux-gnu":         "endian-big bit-32 common-linux common-glibc",\
-               "viac3-linux-gnu":         "endian-little bit-32 common-linux common-glibc ix86-common",\
-               "x86_64-linux-gnu":        "endian-little bit-64 common-linux common-glibc",\
+               "sparc-linux":         "endian-big bit-32 common-linux common-glibc",\
+               "viac3-linux":         "endian-little bit-32 common-linux common-glibc ix86-common",\
                "x86_64-linux":            "endian-little bit-64 common-linux common-glibc",\
                "x86_64-linux-uclibc":     "endian-little bit-64 common-linux common-uclibc"}
        if target in targetinfo:
index ab3606d..47147a1 100644 (file)
@@ -1,12 +1,12 @@
 # eglibc:
 require conf/distro/include/eglibc.inc
 
-TARGET_OS = "linux-gnu"
+TARGET_OS = "linux"
 
 TARGET_OS .= "${@['','eabi'][bb.data.getVar('TARGET_ARCH',d,1) in ['arm', 'armeb'] and bb.data.getVar('MACHINE',d) not in ['collie','h3600', 'h3800', 'simpad', 'htcwallaby']]}"
 TARGET_OS .= "${@['','spe'][bb.data.getVar('TARGET_ARCH',d,1) in ['ppc', 'powerpc'] and bb.data.getVar('MACHINE',d) in ['calamari']]}"
 
-#TARGET_OS = "linux-gnuspe"
+#TARGET_OS = "linux-spe"
 
 #mess with compiler flags to use -Os instead of -O2
 #Please see http://free-electrons.com/doc/embedded_linux_optimizations/img47.html for some more info
index 544ee4a..28c31e3 100644 (file)
@@ -3,7 +3,7 @@ require conf/distro/include/glibc.inc
 
 PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers"
 
-TARGET_OS = "linux-gnu"
+TARGET_OS = "linux"
 TARGET_OS .= "${@['','eabi'][bb.data.getVar('TARGET_ARCH',d,1) in ['arm', 'armeb'] and bb.data.getVar('MACHINE',d) not in ['collie','h3600', 'h3800', 'simpad', 'htcwallaby']]}"
 
 #mess with compiler flags to use -Os instead of -O2
index 9351187..561c97a 100644 (file)
@@ -157,16 +157,16 @@ def detect_arm_abi (d):
 def compute_os_portion_of_target_triplet (d):
        import bb
        arm_eabi_supporting_arches = "armv6 armv6-novfp \
-       armv5te iwmmxt armv7a armv7 armv6 armv5teb armv4t"
+       armv5te iwmmxt armv7a armv7 armv5teb armv4t"
        ppc_spe_supporting_arches = "ppce500v2 ppce500"
 
        if bb.data.getVar("LIBC", d, 1) == "uclibc":
                libc_suffix = "uclibc"
        else:
-               libc_suffix = "gnu"
+               libc_suffix = ""
        
        if bb.data.getVar('TARGET_ARCH',d,1) in ['bfin']:
-               if libc_suffix == "gnu":
+               if libc_suffix is not "uclibc":
                        bb.fatal("bfin is not supported on glibc/eglibc. Please choose uclibc")
                else:
                        os_suffix = "uclinux"
@@ -182,7 +182,7 @@ def compute_os_portion_of_target_triplet (d):
                                bb.fatal("DISTRO requested EABI but selected machine does not support EABI")
                                abi_suffix = ""
                        else:
-                               abi_suffix = "eabi"
+                               abi_suffix = "gnueabi"
                elif bparch in ppc_spe_supporting_arches.split():
                        abi_suffix = "spe"
                else:
@@ -190,7 +190,10 @@ def compute_os_portion_of_target_triplet (d):
        else:
                bb.note("DISTRO_FEATURES is not set abi suffix not set")
                abi_suffix = ""
-       return os_suffix + "-" + libc_suffix + abi_suffix
+       if libc_suffix is not "" or abi_suffix is not "":
+               return os_suffix + "-" + libc_suffix + abi_suffix
+       else:
+               return os_suffix
 
 # This is needed to get a correct PACKAGE_ARCH for packages that have PACKAGE_ARCH = ${MACHINE_ARCH}
 ARM_ABI = "${@detect_arm_abi(d)}"
index 1bb540e..243b5da 100644 (file)
@@ -21,9 +21,8 @@ export LSOF_OS = "${TARGET_OS}"
 LSOF_OS_linux-uclibc = "linux"
 LSOF_OS_linux-uclibceabi = "linux"
 LSOF_OS_linux-uclibspe = "linux"
-LSOF_OS_linux-gnu = "linux"
 LSOF_OS_linux-gnueabi = "linux"
-LSOF_OS_linux-gnuspe = "linux"
+LSOF_OS_linux-spe = "linux"
 export LSOF_INCLUDE = "${STAGING_INCDIR}"
 
 do_configure () {
index 4c6e435..8b8e870 100644 (file)
@@ -35,7 +35,7 @@ do_configure () {
                os=linux
        elif [ "x$os" = "xlinux-uclibceabi" ]; then
                os=linux
-       elif [ "x$os" = "xlinux-gnu" ]; then
+       elif [ "x$os" = "xlinux-gnueabi" ]; then
                os=linux
        fi
        target="$os-${HOST_ARCH}"
@@ -70,7 +70,7 @@ do_configure () {
        linux-powerpc)
                target=linux-ppc
                ;;
-       linux-gnuspe-powerpc)
+       linux-spe-powerpc)
                target=linux-ppc
                ;;
        linux-supersparc)
similarity index 100%
rename from site/arm-linux-gnu
rename to site/arm-linux
similarity index 100%
rename from site/armeb-linux-gnu
rename to site/armeb-linux
similarity index 100%
rename from site/mips-linux-gnu
rename to site/mips-linux
similarity index 100%
rename from site/mipsel-linux-gnu
rename to site/mipsel-linux
similarity index 100%
rename from site/powerpc-linux-gnu
rename to site/powerpc-linux
similarity index 100%
rename from site/sparc-linux-gnu
rename to site/sparc-linux
similarity index 100%
rename from site/x86_64-linux-gnu
rename to site/x86_64-linux