libgles-omap3: load specific modules, avoid devnode recreation sz_beta5
authorGrazvydas Ignotas <notasas@gmail.com>
Wed, 23 May 2012 00:13:14 +0000 (03:13 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Wed, 23 May 2012 00:29:53 +0000 (03:29 +0300)
this is for compatibility with Nokia's SGX kernel driver

recipes/powervr-drivers/libgles-omap3/rc.pvr
recipes/powervr-drivers/libgles-omap3_4.00.00.01.bb

index 514d577..0b1aba0 100755 (executable)
@@ -32,23 +32,23 @@ fbset -vyres $(expr $YRES \* 3)
 
 if [ $CPUTYPE = "OMAP3530" ]; then
        echo Starting PVR
-       insmod $(busybox find /lib/modules/$(uname -r) -name "pvrsrvkm.ko")
-       modprobe omaplfb
-       modprobe bufferclass_ti
+       insmod /lib/modules/$(uname -r)/kernel/drivers/gpu/pvrsrvkm.ko
+       insmod /lib/modules/$(uname -r)/kernel/drivers/gpu/omaplfb.ko
+       insmod /lib/modules/$(uname -r)/kernel/drivers/gpu/bufferclass_ti.ko
 
        if ! lsmod | grep -q pvrsrvkm; then
                echo pvrsrvkm failed to load
                exit 1
        fi
 
-       pvr_maj=`grep "pvrsrvkm$" /proc/devices | cut -b1,2,3`
-        bc_maj=`grep "bc" /proc/devices | cut -b1,2,3`
+       #pvr_maj=`grep "pvrsrvkm$" /proc/devices | cut -b1,2,3`
+        #bc_maj=`grep "bc" /proc/devices | cut -b1,2,3`
 
-       if [ -e /dev/pvrsrvkm ] ; then 
-               rm -f /dev/pvrsrvkm
-       fi
+       #if [ -e /dev/pvrsrvkm ] ; then 
+       #       rm -f /dev/pvrsrvkm
+       #fi
 
-       mknod /dev/pvrsrvkm c $pvr_maj 0 
+       #mknod /dev/pvrsrvkm c $pvr_maj 0 
        chmod 666 /dev/pvrsrvkm
 
        touch /etc/powervr-esrev
index cd26be7..ebfba66 100644 (file)
@@ -10,7 +10,7 @@ require libgles-omap3.inc
 # http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
 # see libgles-omap3.inc for detailed installation instructions
 
-PR = "r3"
+PR = "r4"
 
 SGXPV = "4_00_00_01"
 IMGPV = "1.4.14.2616"