obexpush: update INITSCRIPT_PARAMS to use only one digit param
authorMartin Jansa <Martin.Jansa@gmail.com>
Wed, 9 Dec 2009 16:40:31 +0000 (17:40 +0100)
committerMartin Jansa <Martin.Jansa@gmail.com>
Wed, 9 Dec 2009 16:45:47 +0000 (17:45 +0100)
* update-rc.d_0.7 calls "printf %02d 09" inside and 09 is considered as
  octal number and it fails, then stop parameter is used as 00 and "sh:
  09: invalid number" is shown in postinst.
* Maybe this should be fixed in update-rc.d as it suggests to use both
  digits "update-rc.d [-n] [-r <root>] [-s] <basename> defaults [NN | sNN
  kNN]" which is quite misleading as you cannot use 's' or 'k' as
  prefix.

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
recipes/obexpush/obexpush_1.0.0.bb

index 13b8508..4de4cbe 100644 (file)
@@ -14,7 +14,7 @@ S = "${WORKDIR}/obexpush"
 inherit update-rc.d
 
 INITSCRIPT_NAME = "opd"
-INITSCRIPT_PARAMS = "defaults 33 09"
+INITSCRIPT_PARAMS = "defaults 33 9"
 
 export GLIBINC = "-I${STAGING_INCDIR}/glib-2.0"
 export GLIBLIB = "-I${STAGING_LIBDIR} -lglib-2.0"