nmon: new recipe; flexible ncurses-based performance monitor
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Sun, 16 May 2010 10:38:22 +0000 (12:38 +0200)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Sun, 16 May 2010 10:38:22 +0000 (12:38 +0200)
recipes/nmon/nmon_13g.bb [new file with mode: 0644]

diff --git a/recipes/nmon/nmon_13g.bb b/recipes/nmon/nmon_13g.bb
new file mode 100644 (file)
index 0000000..0aa4095
--- /dev/null
@@ -0,0 +1,22 @@
+DESCRIPTION = "nmon performance monitor"
+HOMEPAGE = "http://nmon.sf.net"
+SECTION = "console/utils"
+LICENSE = "GPL"
+DEPENDS = "ncurses"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/nmon/lmon13g.c"
+
+SRC_URI[md5sum] = "b1b8e6c0123ad232394991f2d4f40494"
+SRC_URI[sha256sum] = "456ab2a342b31d1a352d0d940af5962fa65a12ae8757ff73e6e73210832ae8b5"
+
+CFLAGS += "-D JFS -D GETUSER -Wall -D LARGEMEM"
+LDFLAGS += "-lncurses"
+
+do_compile() {
+       ${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/lmon13g.c -o nmon
+}
+
+do_install() {
+       install -d ${D}${bindir}
+       install -m 0755 nmon ${D}${bindir}
+}