xf86-input-tslib: make it build against XServer 1.6
authorMarcin Juszkiewicz <marcin@buglabs.net>
Wed, 27 May 2009 16:23:11 +0000 (18:23 +0200)
committerMarcin Juszkiewicz <marcin@buglabs.net>
Wed, 27 May 2009 16:23:11 +0000 (18:23 +0200)
recipes/xorg-driver/xf86-input-tslib/xserver16.patch [new file with mode: 0644]
recipes/xorg-driver/xf86-input-tslib_0.0.5.bb

diff --git a/recipes/xorg-driver/xf86-input-tslib/xserver16.patch b/recipes/xorg-driver/xf86-input-tslib/xserver16.patch
new file mode 100644 (file)
index 0000000..c3108b6
--- /dev/null
@@ -0,0 +1,26 @@
+XServer 1.6.x introduced XInput3. Official drivers were fixed by X.org
+developers. This change is based on xf86-input-citron:
+
+http://cgit.freedesktop.org/xorg/driver/xf86-input-citron/commit/?id=591674bee43061f1169ebeede653fb6d98147724
+
+Signed-off-by: Marcin Juszkiewicz <marcin@buglabs.net>
+---
+ src/tslib.c |    2 ++
+ 1 file changed, 2 insertions(+)
+
+--- xf86-input-tslib-0.0.5.orig/src/tslib.c
++++ xf86-input-tslib-0.0.5/src/tslib.c
+@@ -199,11 +199,13 @@ xf86TslibControlProc(DeviceIntPtr device
+                       return !Success;
+               }
+               if (InitValuatorClassDeviceStruct(device,
+                                                 2,
++#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) < 3
+                                                 xf86GetMotionEvents,
++#endif
+                                                 0, Absolute) == FALSE) {
+                       ErrorF("unable to allocate Valuator class device\n");
+                       return !Success;
+               }
index f5c0186..6652760 100644 (file)
@@ -4,12 +4,13 @@ DESCRIPTION = "X.Org X server -- tslib input driver"
 RRECOMMENDS += "hal"
 DEPENDS += "tslib"
 
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "http://www.pengutronix.de/software/xf86-input-tslib/download/xf86-input-tslib-${PV}.tar.bz2 \
            file://use-hal-for-device.diff;patch=1 \
            file://01_fix-wrong-value-range-for-the-axises.diff;patch=1 \
            file://dynamic-xy.patch;patch=1 \
+           file://xserver16.patch;patch=1 \
            file://10-x11-input-tslib.fdi"
 
 do_configure_prepend() {