links: update to 2.13
authorGrazvydas Ignotas <notasas@gmail.com>
Tue, 29 Nov 2016 23:00:20 +0000 (01:00 +0200)
committerGrazvydas Ignotas <notasas@gmail.com>
Tue, 29 Nov 2016 23:00:20 +0000 (01:00 +0200)
recipes/links/files/ac-prog-cxx.patch
recipes/links/files/cookies-save-0.96.patch [deleted file]
recipes/links/files/links-2.1pre17-fix-segfault-on-loading-cookies.patch [deleted file]
recipes/links/files/links2.desktop
recipes/links/links-x11_2.0+2.1pre30.bb [deleted file]
recipes/links/links-x11_2.13.bb [new file with mode: 0644]
recipes/links/links.inc
recipes/links/links_2.0+2.1pre30.bb [deleted file]
recipes/links/links_2.13.bb [new file with mode: 0644]

index 41c3826..c5f3850 100644 (file)
@@ -1,11 +1,12 @@
---- links-2.1pre20/configure.in.orig   2005-12-21 15:23:49.000000000 +0000
-+++ links-2.1pre20/configure.in        2005-12-21 15:23:59.000000000 +0000
-@@ -18,7 +18,7 @@
+diff -ur links-2.13_/configure.in links-2.13/configure.in
+--- links-2.13_/configure.in   2016-06-27 01:46:14.000000000 +0300
++++ links-2.13/configure.in    2016-11-26 19:47:18.618525341 +0200
+@@ -23,7 +23,7 @@
  dnl Checks for programs.
  AC_PROG_CC
  
--#AC_PROG_CXX
+-dnl AC_PROG_CXX
 +AC_PROG_CXX
#AC_PROG_AWK
#AM_PROG_LEX
#AC_PROG_YACC
dnl AC_PROG_AWK
dnl AM_PROG_LEX
dnl AC_PROG_YACC
diff --git a/recipes/links/files/cookies-save-0.96.patch b/recipes/links/files/cookies-save-0.96.patch
deleted file mode 100644 (file)
index a1e35c0..0000000
+++ /dev/null
@@ -1,106 +0,0 @@
-diff -ru links-0.96/cookies.c links-0.96+cookies-save/cookies.c
---- links-0.96/cookies.c       Mon Sep  3 07:19:37 2001
-+++ links-0.96+cookies-save/cookies.c  Mon Sep  3 07:18:42 2001
-@@ -276,15 +276,99 @@
- void init_cookies(void)
- {
--      /* !!! FIXME: read cookies */
-+      unsigned char in_buffer[MAX_STR_LEN];
-+      unsigned char *cookfile, *p, *q;
-+      FILE *fp;
-+
-+      /* must be called after init_home */
-+      if (! links_home) return;
-+      
-+      cookfile = stracpy(links_home);
-+      if (! cookfile) return;
-+      add_to_strn(&cookfile, "cookies");
-+
-+      fp = fopen(cookfile, "r");
-+      mem_free(cookfile);
-+      if (fp == NULL) return;
-+      
-+      while (fgets(in_buffer, MAX_STR_LEN, fp)) {
-+              struct cookie *cookie;
-+              
-+              if (!(cookie = mem_alloc(sizeof(struct cookie)))) return;
-+              memset(cookie, 0, sizeof(struct cookie));
-+              
-+              q = in_buffer; p = strchr(in_buffer, ' ');
-+              if (p == NULL) goto inv;
-+              *p++ = '\0';
-+              cookie->name = stracpy(q);
-+              
-+              q = p; p = strchr(p, ' ');
-+              if (p == NULL) goto inv;
-+              *p++ = '\0';
-+              cookie->value = stracpy(q);
-+              
-+              q = p; p = strchr(p, ' ');
-+              if (p == NULL) goto inv;
-+              *p++ = '\0';
-+              cookie->server = stracpy(q);
-+              
-+              q = p; p = strchr(p, ' ');
-+              if (p == NULL) goto inv;
-+              *p++ = '\0';
-+              cookie->path = stracpy(q);
-+              
-+              q = p; p = strchr(p, ' ');
-+              if (p == NULL) goto inv;
-+              *p++ = '\0';
-+              cookie->domain = stracpy(q);
-+              
-+              q = p; p = strchr(p, ' ');
-+              if (p == NULL) goto inv;
-+              *p++ = '\0';
-+              cookie->expires = atoi(q);
-+              
-+              cookie->secure = atoi(p);
-+              
-+              cookie->id = cookie_id++;
-+
-+              accept_cookie(cookie);
-+
-+              continue;
-+
-+inv:
-+              free_cookie(cookie);
-+              free(cookie);
-+      }
-+      fclose(fp);
- }
- void cleanup_cookies(void)
- {
-       struct cookie *c;
-+      unsigned char *cookfile;
-+      FILE *fp;
-+      
-       free_list(c_domains);
--      /* !!! FIXME: save cookies */
--      foreach (c, cookies) free_cookie(c);
-+
-+      cookfile = stracpy(links_home);
-+      if (! cookfile) return;
-+      add_to_strn(&cookfile, "cookies");
-+
-+      fp = fopen(cookfile, "w");
-+      mem_free(cookfile);
-+      if (fp == NULL) return;
-+      
-+      foreach (c, cookies) {
-+              if (c->expires && ! cookie_expired(c))
-+                      fprintf(fp, "%s %s %s %s %s %d %d\n", c->name, c->value,
-+                          c->server?c->server:(unsigned char *)"", c->path?c->path:(unsigned char *)"",
-+                          c->domain?c->domain:(unsigned char *)"", c->expires, c->secure);
-+
-+              free_cookie(c);
-+      }
-+
-+      fclose(fp);
-+      
-       free_list(cookies);
- }
diff --git a/recipes/links/files/links-2.1pre17-fix-segfault-on-loading-cookies.patch b/recipes/links/files/links-2.1pre17-fix-segfault-on-loading-cookies.patch
deleted file mode 100644 (file)
index 0d3b407..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- links-2.1pre17/cookies.c.pix       2005-05-15 23:05:10.000000000 +0800
-+++ links-2.1pre17/cookies.c   2005-05-15 23:17:21.000000000 +0800
-@@ -41,7 +41,7 @@
- void free_cookie(struct cookie *c)
- {
--      mem_free(c->name);
-+      if (c->value) mem_free(c->name);
-       if (c->value) mem_free(c->value);
-       if (c->server) mem_free(c->server);
-       if (c->path) mem_free(c->path);
-@@ -355,7 +355,7 @@
- inv:
-               free_cookie(cookie);
--              free(cookie);
-+              mem_free(cookie);
-       }
-       fclose(fp);
- }
index a05bce1..f85b985 100644 (file)
@@ -7,8 +7,6 @@ Comment[pl]=Links jest przeglądarką podobną do lynksa
 Comment[pt]=O links é um browser para modo texto, similar ao lynx
 Comment[pt_BR]=O links é um browser para modo texto, similar ao lynx
 Exec=links -g
-Terminal=true
 Icon=links2
 Type=Application
 Categories=Application;ConsoleOnly;Network;WebBrowser;
-# vi: encoding=utf-8
diff --git a/recipes/links/links-x11_2.0+2.1pre30.bb b/recipes/links/links-x11_2.0+2.1pre30.bb
deleted file mode 100644 (file)
index 9ee70d9..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-require links.inc
-
-DEPENDS += "virtual/libx11"
-RCONFLICTS = "links"
-PR = "r1"
-
-SRC_URI += " file://links2.desktop \
-             http://www.xora.org.uk/oe/links2.png"
-
-EXTRA_OECONF = "--enable-javascript --with-libfl --enable-graphics \
-               --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \
-               --without-libtiff --without-svgalib --without-fb \
-               --without-directfb --without-pmshell --without-atheos \
-               --with-x --without-gpm --without-sdl"
-
-do_install_append() {
-        install -d ${D}/${datadir}/applications
-        install -m 0644 ${WORKDIR}/links2.desktop ${D}/${datadir}/applications
-        install -d ${D}/${datadir}/pixmaps
-        install -m 0644 ${WORKDIR}/links2.png ${D}/${datadir}/pixmaps
-}
-
diff --git a/recipes/links/links-x11_2.13.bb b/recipes/links/links-x11_2.13.bb
new file mode 100644 (file)
index 0000000..8bba853
--- /dev/null
@@ -0,0 +1,31 @@
+require links.inc
+
+DEPENDS += "virtual/libx11"
+RCONFLICTS_${PN} = "links"
+
+#inherit distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI += " file://links2.desktop \
+             http://www.xora.org.uk/oe/links2.png;name=icon"
+
+S = "${WORKDIR}/links-${PV}"
+
+EXTRA_OECONF += "--enable-graphics \
+                --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \
+                --without-libtiff --without-svgalib --without-fb \
+                --without-directfb --without-pmshell --without-atheos \
+                --with-x --without-gpm --with-bzip2 --with-lzma"
+
+do_install_append() {
+    install -d ${D}/${datadir}/applications
+    install -m 0644 ${WORKDIR}/links2.desktop ${D}/${datadir}/applications
+    install -d ${D}/${datadir}/pixmaps
+    install -m 0644 ${WORKDIR}/links2.png ${D}/${datadir}/pixmaps
+}
+
+SRC_URI[md5sum] = "af418c83909ee73c09b95470bda6e377"
+SRC_URI[sha256sum] = "c252095334a3b199fa791c6f9a9affe2839a7fbd536685ab07851cb7efaa4405"
+SRC_URI[icon.md5sum] = "477e8787927c634614bac01b44355a33"
+SRC_URI[icon.sha256sum] = "eddcd8b8c8698aa621d1a453943892d77b72ed492e0d14e0dbac5c6a57e52f47"
index 2d299d3..0310643 100644 (file)
@@ -2,17 +2,20 @@ DESCRIPTION = "Links is graphics and text mode WWW \
 browser, similar to Lynx."
 HOMEPAGE = "http://links.twibright.com/"
 SECTION = "console/network"
-LICENSE = "GPL"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=65e735be2e05d5943803344148f57603"
 DEPENDS = "jpeg libpng flex openssl zlib"
 
-LPV = "${@bb.data.getVar("PV",d,1).split("+")[1]}"
-
-SRC_URI = "http://links.twibright.com/download/links-${LPV}.tar.bz2 \
+SRC_URI = "http://links.twibright.com/download/links-${PV}.tar.bz2 \
            file://ac-prog-cxx.patch;patch=1 \
-           file://cookies-save-0.96.patch;patch=1 \
-           file://links-2.1pre17-fix-segfault-on-loading-cookies.patch;patch=1"
+"
 
-inherit autotools
+# pandora hack: certs just don't work, no idea why
+CPPFLAGS += -DNO_SSL_CERTIFICATES
 
-S = "${WORKDIR}/links-${LPV}"
+#PACKAGECONFIG ??= ""
+#PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
+#PACKAGECONFIG[lzma] = "--with-lzma,--without-lzma,xz"
+EXTRA_OECONF += " --with-bzip2 --with-lzma --without-libevent"
 
+inherit autotools pkgconfig
diff --git a/recipes/links/links_2.0+2.1pre30.bb b/recipes/links/links_2.0+2.1pre30.bb
deleted file mode 100644 (file)
index c46a64f..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-require links.inc
-
-DEPENDS += "gpm"
-RCONFLICTS = "links-x11"
-PR = "r1"
-
-EXTRA_OECONF = "--enable-javascript --with-libfl --enable-graphics \
-               --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \
-               --without-libtiff --without-svgalib --with-fb \
-               --without-directfb --without-pmshell --without-atheos \
-               --without-x --without-sdl"
diff --git a/recipes/links/links_2.13.bb b/recipes/links/links_2.13.bb
new file mode 100644 (file)
index 0000000..2cfb98c
--- /dev/null
@@ -0,0 +1,13 @@
+require links.inc
+
+DEPENDS += "gpm"
+RCONFLICTS_${PN} = "links-x11"
+
+EXTRA_OECONF += "--enable-graphics \
+                --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \
+                --without-libtiff --without-svgalib --with-fb \
+                --without-directfb --without-pmshell --without-atheos \
+                --without-x --with-bzip2 --with-lzma"
+
+SRC_URI[md5sum] = "af418c83909ee73c09b95470bda6e377"
+SRC_URI[sha256sum] = "c252095334a3b199fa791c6f9a9affe2839a7fbd536685ab07851cb7efaa4405"