libsdl: use new .inc for 2.1.14 version
authorHenning Heinold <heinold@inf.fu-berlin.de>
Tue, 8 Feb 2011 22:31:53 +0000 (23:31 +0100)
committerHenning Heinold <heinold@inf.fu-berlin.de>
Tue, 8 Feb 2011 22:34:46 +0000 (23:34 +0100)
* make autotools-usage and libtool2.4 from directfb generic,
  this fixes libsdl-x11 too
* switch to INC_PR

recipes/libsdl/libsdl-1.2.14.inc [new file with mode: 0644]
recipes/libsdl/libsdl-directfb_1.2.14.bb
recipes/libsdl/libsdl-x11_1.2.14.bb

diff --git a/recipes/libsdl/libsdl-1.2.14.inc b/recipes/libsdl/libsdl-1.2.14.inc
new file mode 100644 (file)
index 0000000..5c43310
--- /dev/null
@@ -0,0 +1,26 @@
+DESCRIPTION = "Simple DirectMedia Layer (DirectFB and Framebuffer support)"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "alsa-lib"
+PROVIDES = "virtual/libsdl"
+INC_PR = "r1"
+
+SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz"
+SRC_URI[md5sum] = "e52086d1b508fa0b76c52ee30b55bec4"
+SRC_URI[sha256sum] = "5d927e287034cb6bb0ebccfa382cb1d185cb113c8ab5115a0759798642eed9b6"
+
+S = "${WORKDIR}/SDL-${PV}"
+
+inherit autotools lib_package binconfig pkgconfig
+
+EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
+
+do_configure_prepend () {
+        # Remove old libtool macros.
+        MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
+        for i in ${MACROS}; do
+               rm -f acinclude/$i
+        done
+       export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
+}
index 4a3dab0..4824b83 100644 (file)
@@ -1,17 +1,8 @@
-DESCRIPTION = "Simple DirectMedia Layer (DirectFB and Framebuffer support)"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "LGPL"
-DEPENDS = "alsa-lib directfb"
-PROVIDES = "virtual/libsdl"
+require libsdl-1.2.14.inc
 
-SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz"
-SRC_URI[md5sum] = "e52086d1b508fa0b76c52ee30b55bec4"
-SRC_URI[sha256sum] = "5d927e287034cb6bb0ebccfa382cb1d185cb113c8ab5115a0759798642eed9b6"
+PR = "${INC_PR}.1"
 
-S = "${WORKDIR}/SDL-${PV}"
-
-inherit autotools lib_package binconfig pkgconfig
+DEPENDS += "directfb"
 
 EXTRA_OECONF = " \
         --disable-arts \
@@ -35,13 +26,3 @@ EXTRA_OECONF = " \
         --disable-video-qtopia \
         --disable-video-x11 \
 "
-EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
-
-do_configure_prepend () {
-        # Remove old libtool macros.
-        MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
-        for i in ${MACROS}; do
-               rm -f acinclude/$i
-        done
-       export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
-}
index 5417ba3..17e4adb 100644 (file)
@@ -1,24 +1,9 @@
-# Do not use the include in 1.2.14 as it has a lot of unneeded munging that applies to old versions.
-#require libsdl.inc
+require libsdl-1.2.14.inc
 
-DESCRIPTION = "Simple DirectMedia Layer (X11 and Framebuffer support)"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "LGPL"
-DEPENDS = "alsa-lib virtual/libgl virtual/libx11 libxext tslib"
-DEPENDS_avr32 = "alsa-lib virtual/libx11 libxext tslib"
-PROVIDES = "virtual/libsdl"
-PR = "r7"
+DEPENDS += "virtual/libgl virtual/libx11 libxext tslib"
+DEPENDS_avr32 += "alsa-lib virtual/libx11 libxext tslib"
 
-SRC_URI = " \
-  http://www.libsdl.org/release/SDL-${PV}.tar.gz \
-  file://sdl_bug_894_fix.patch \
-  file://sdl.m4 \
-"
-
-S = "${WORKDIR}/SDL-${PV}"
-
-inherit autotools binconfig pkgconfig
+PR = "${INC_PR}.8"
 
 EXTRA_OECONF = " \
   --disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
@@ -31,28 +16,3 @@ EXTRA_OECONF = " \
   --disable-video-picogui --disable-video-qtopia --enable-dlopen \
   --enable-input-tslib --disable-video-ps3 --disable-rpath \
 "
-
-do_configure() { 
-  oe_runconf
-}
-
-do_configure_append () {
-  cd ${S}
-
-  # prevent libtool from linking libs against libstdc++, libgcc, ...
-  cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
-  mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
-
-  # copy new sdl.m4 macrofile to the dir for installing
-  cp ${WORKDIR}/sdl.m4 ${S}/
-}
-
-do_install_append() {
-  rm ${D}${libdir}/libSDL.la
-}
-
-FILES_${PN} = "${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${bindir}/*config"
-
-SRC_URI[md5sum] = "e52086d1b508fa0b76c52ee30b55bec4"
-SRC_URI[sha256sum] = "5d927e287034cb6bb0ebccfa382cb1d185cb113c8ab5115a0759798642eed9b6"