Revert "Revert "qt4: Updated to v4.7.3"
[openembedded.git] / recipes / qt4 / qt4-tools-sdk_4.6.0.bb
1 DESCRIPTION = "SDK tools for Qt/[X11|Mac|Embedded] version 4.x"
2 DEPENDS = "zlib-native dbus-native"
3 SECTION = "libs"
4 HOMEPAGE = "http://www.trolltech.com"
5 PRIORITY = "optional"
6 LICENSE = "LGPLv2.1 GPLv3"
7
8 DEFAULT_PREFERENCE = "-1"
9 inherit sdk
10
11 SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-${PV}.tar.gz \
12            file://configure-lflags.patch;patch=1 \
13            file://qt-config.patch;patch=1 \
14            file://g++.conf \
15            file://linux.conf"
16
17 S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
18
19
20 # FIXME: make it work with "${STAGING_BINDIR_NATIVE}/pkg-config --cflags dbus-1"
21 EXTRA_OECONF = "-prefix ${prefix} \
22                 -qt-libjpeg -qt-gif -system-zlib \
23                 -no-libjpeg -no-libpng \
24                 -no-accessibility \
25                 -no-cups \
26                 -no-exceptions  \
27                 -no-nas-sound \
28                 -no-nis \
29                 -verbose -release -fast -static \
30                 -qt3support \
31                 -I${STAGING_DIR_NATIVE}/usr/include \
32                 -I${STAGING_DIR_NATIVE}/usr/include/dbus-1.0 \
33                 -I${STAGING_DIR_NATIVE}/usr/lib/dbus-1.0/include"
34
35 # yank default -e, otherwise we get the following error:
36 # moc_qbuffer.cpp: No such file or directory
37 EXTRA_OEMAKE = " "
38
39 do_configure() {
40    (echo o; echo yes) | ./configure ${EXTRA_OECONF} || die "Configuring qt failed. EXTRA_OECONF was ${EXTRA_OECONF}"
41 }
42
43 TOBUILD = "\
44   src/tools/bootstrap \
45   src/tools/moc \
46   src/corelib \
47   src/sql \
48   src/dbus \
49   src/qt3support \
50   src/xml \
51   src/tools/uic \
52   src/tools/rcc \
53   src/network \
54   src/gui \
55   src/tools/uic3 \
56   tools/linguist/lrelease \
57   tools/linguist/lupdate \
58   tools/qdbus \
59 "
60
61 do_compile() {
62     for i in ${TOBUILD}; do
63         cd ${S}/$i && oe_runmake CC="${CC}" CXX="${CXX}"
64     done
65 }
66
67 do_install() {
68     install -d ${D}${bindir}
69     install -m 0755 bin/qmake ${D}${bindir}/qmake2
70     for i in moc uic uic3 rcc lrelease lupdate qdbuscpp2xml qdbusxml2cpp; do
71         install -m 0755 bin/${i} ${D}${bindir}/${i}4
72     done
73 }
74