libgles-omap3: try to deal with replacement issue
[openembedded.git] / recipes / powervr-drivers / libgles-omap3-es23_4.00.00.01.bb
1 BINLOCATION = "${S}/gfx_rel_es3.x"
2
3 ES2LOCATION = "${S}/gfx_rel_es2.x"
4 ES3LOCATION = "${S}/gfx_rel_es3.x"
5 ES5LOCATION = "none"
6
7 require libgles-omap3.inc
8
9 PR = "r1"
10
11 SGXPV = "4_00_00_01"
12 IMGPV = "1.4.14.2616"
13 BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
14
15 # init script needs this to be in place
16 RDEPENDS_${PN} += "libgles-omap3-dm3730"
17
18 SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \
19                    file://cputype \
20                    file://rc.pvr \
21                    file://sample.desktop \
22                    file://99-bufferclass.rules  \
23 "
24
25 SRC_URI[md5sum] = "a027002dcd7164df467b1a315788d5fd"
26 SRC_URI[sha256sum] = "62383d15e33adf9349afba063b0f2405a15aa6c4b0b5579b0abdf81db7580df7"
27
28 S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
29
30 # upgrade path
31 RCONFLICTS = "libgles-omap3"
32 RREPLACES_${PN} = "libgles-omap3"
33 RREPLACES_${PN}-rawdemos = "libgles-omap3-rawdemos"
34 RREPLACES_${PN}-x11demos = "libgles-omap3-x11demos"
35 RREPLACES_${PN}-rawtrainingcourses = "libgles-omap3-rawtrainingcourses"
36 RREPLACES_${PN}-x11trainingcourses = "libgles-omap3-x11trainingcourses"
37 RREPLACES_${PN}-tests = "libgles-omap3-tests"