xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / recipes / netkit-telnet / netkit-telnet_0.17.bb
1 SECTION = "base"
2 DESCRIPTION = "netkit-telnet includes the telnet daemon and client."
3 DEPENDS = "ncurses"
4 LICENSE = "BSD"
5 PR = "r1"
6
7 SRC_URI = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-telnet-${PV}.tar.gz \
8            file://netkit-telnet-debian_0.17-36.diff;patch=1 \
9            file://cross-compile.patch;patch=1 "
10
11 do_configure () {
12     ./configure --prefix=${prefix}
13
14     # Inject our ldflags into the config... it is not horning them otherwise
15     echo "LDFLAGS=${LDFLAGS}" > MCONFIG
16 }
17
18
19 do_compile () {
20         oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' SUB=telnet
21 }
22
23 do_install () {
24     install -d ${D}${bindir}
25     install -m 0755 telnet/telnet ${D}${bindir}/telnet.${PN}
26 }
27
28 pkg_postinst_${PN} () {
29 #!/bin/sh
30     update-alternatives --install ${bindir}/telnet telnet telnet.${PN} 100
31 }
32
33 pkg_prerm_${PN} () {
34  #!/bin/sh
35    update-alternatives --remove telnet telnet.${PN} 100
36 }
37