libav: add proper recipe for git version
[openembedded.git] / recipes / libav / libav_git.bb
1 require libav.inc
2
3 DEPENDS += "virtual/libsdl schroedinger libgsm libvpx"
4
5 # When bumping SRCREV make sure you bump PR here and in dependant recipes (gst-ffmpeg, gnash, omxil, etc) to account for SOVERSION changes
6 SRCREV = "c6c2dfcf15c1d93b2189adff6f71c5c4b6b05338"
7
8 PV = "0.6.2+${PR}+gitr${SRCPV}"
9 PR = "${INC_PR}.2"
10
11 SRC_URI = "git://git.libav.org/libav.git;protocol=git"
12
13 S = "${WORKDIR}/git"
14 B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
15
16 FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations  -fno-tree-vectorize -fomit-frame-pointer -O4 -ffast-math"
17 BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
18
19 EXTRA_FFCONF_armv7a = "--cpu=cortex-a8"
20 EXTRA_FFCONF ?= ""
21
22 EXTRA_OECONF = " \
23         --enable-shared \
24         --enable-pthreads \
25         --disable-stripping \
26         --enable-gpl \
27         --enable-postproc \
28         \
29         --cross-prefix=${TARGET_PREFIX} \
30         --prefix=${prefix} \
31         \
32         --enable-ffserver \
33         --enable-ffplay \
34         --enable-x11grab \
35         --enable-libgsm \
36         --enable-libmp3lame \
37         --enable-libschroedinger \
38         --enable-libtheora  \
39         --enable-libvorbis \
40         --enable-libvpx \
41         --arch=${TARGET_ARCH} \
42         --target-os="linux" \
43         --enable-cross-compile \
44         --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
45         --extra-ldflags="${TARGET_LDFLAGS}" \
46         --sysroot="${STAGING_DIR_TARGET}" \
47         --enable-hardcoded-tables \
48         ${EXTRA_FFCONF} \
49 "
50
51 do_configure() {
52         mkdir -p ${B}
53         cd ${B}
54         ${S}/configure ${EXTRA_OECONF}
55         sed -i -e s:Os:O4:g ${B}/config.h
56 }
57