zaurus-2.6.inc: default to standard linux kernel recipe for all devices.
[openembedded.git] / recipes / classpath / inetlib_1.1.1.bb
1 DESCRIPTION = "A Java library of clients for common internet protocols"
2 LICENSE = "GPL + library exception"
3 AUTHOR = "GNU Classpath"
4 HOMEPAGE = "http://gnu.org/software/classpath/inetlib.html"
5
6 SRC_URI = "\
7   http://ftp.gnu.org/gnu/classpath/${BP}.tar.gz \
8   file://datadir_java.patch \
9   "
10
11 inherit java-library autotools
12
13 DEPENDS = "fastjar-native"
14
15 PR = "r1"
16
17 JPN = "libgnuinet-java"
18
19 export JAVAC = "javac"
20
21 export JAVA = "java"
22
23 # We fake this, it is not neccessary anyway.
24 export JAVADOC = "true"
25
26 do_compile() {
27   oe_runmake JARDIR=${datadir_java} inetlib_jar=${JARFILENAME}
28 }
29
30 do_install_append() {
31   java_install
32 }
33
34 SRC_URI[md5sum] = "aaa24be4bc8d172ac675be8bdfa636ee"
35 SRC_URI[sha256sum] = "1b078a39e022f86e4e2c8189b4d2789a5da414e8f1cb285587b7800b950a44de"
36
37 NATIVE_INSTALL_WORKS = "1"
38 BBCLASSEXTEND = "native"