nmon: new recipe; flexible ncurses-based performance monitor
[openembedded.git] / recipes / nmon / nmon_13g.bb
1 DESCRIPTION = "nmon performance monitor"
2 HOMEPAGE = "http://nmon.sf.net"
3 SECTION = "console/utils"
4 LICENSE = "GPL"
5 DEPENDS = "ncurses"
6
7 SRC_URI = "${SOURCEFORGE_MIRROR}/nmon/lmon13g.c"
8
9 SRC_URI[md5sum] = "b1b8e6c0123ad232394991f2d4f40494"
10 SRC_URI[sha256sum] = "456ab2a342b31d1a352d0d940af5962fa65a12ae8757ff73e6e73210832ae8b5"
11
12 CFLAGS += "-D JFS -D GETUSER -Wall -D LARGEMEM"
13 LDFLAGS += "-lncurses"
14
15 do_compile() {
16         ${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/lmon13g.c -o nmon
17 }
18
19 do_install() {
20         install -d ${D}${bindir}
21         install -m 0755 nmon ${D}${bindir}
22 }