wl1251: fix a memory leak in probe
[pandora-wifi.git] / enable-older-kernels / enable-2.6.22.patch
1 --- a/config.mk 2010-01-11 10:27:53.000000000 -0800
2 +++ b/config.mk 2010-01-11 10:32:49.000000000 -0800
3 @@ -26,8 +26,8 @@
4  COMPAT_VERSIONS := $(shell I=$(COMPAT_LATEST_VERSION); while [ "$$I" -gt $(KERNEL_SUBLEVEL) ]; do echo $$I; I=$$(($$I - 1)); done)
5  $(foreach ver,$(COMPAT_VERSIONS),$(eval CONFIG_COMPAT_KERNEL_$(ver)=y))
6  
7 -ifdef CONFIG_COMPAT_KERNEL_25
8 -$(error "ERROR: compat-wireless by default supports kernels >= 2.6.25, try enabling only one driver though")
9 +ifdef CONFIG_COMPAT_WIRELESS_22
10 +$(error "ERROR: compat-wireless for selected driver requires a kernel >= 2.6.22")
11  endif
12  
13  ifeq ($(CONFIG_CFG80211),y)
14 diff --git a/scripts/gen-compat-autoconf.sh b/scripts/gen-compat-autoconf.sh
15 index 6c7cae7..bb2ea6d 100755
16 --- a/scripts/gen-compat-autoconf.sh
17 +++ b/scripts/gen-compat-autoconf.sh
18 @@ -11,7 +11,7 @@
19  
20  # This indicates which is the oldest kernel we support
21  # Update this if you are adding support for older kernels.
22 -OLDEST_KERNEL_SUPPORTED="2.6.25"
23 +OLDEST_KERNEL_SUPPORTED="2.6.22"
24  COMPAT_RELEASE="compat-release"
25  KERNEL_RELEASE="git-describe"
26  MULT_DEP_FILE=".compat_pivot_dep"