task-pandora-xfce: Added the new pandora-lcd-state stuff
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index 4042b9f..ff27287 100755 (executable)
@@ -2,25 +2,31 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r4"
+PR = "r21"
 
 inherit task
 
 ANGSTROM_EXTRA_INSTALL ?= ""
 
 APPS = " \
+  avahi-ui \
   abiword \
   claws-mail \
   swfdec swfdec-gnome swfdec-mozilla \
-  firefox \
+#  firefox \
   gnumeric \   
-  gimp \
+#  gimp \
   networkmanager network-manager-applet \ 
-  synergy \
-  vnc \
-  x11vnc angstrom-x11vnc-xinit \
-  xmms \
-  xterm \
+#  synergy \
+  vnc x11vnc angstrom-x11vnc-xinit \
+  xchat \
+  xournal \
+  arora \
+"
+
+BLUETOOTH_GUI = " \
+  blueman \
+  gnome-bluetooth \
 "
 
 IM_CLIENT = " \
@@ -33,6 +39,7 @@ IM_CLIENT = " \
 
 DISPMAN = " \
   slim \
+  slim-op-themes \
 "
 
 FONTS = " \
@@ -49,34 +56,60 @@ FONTS = " \
   xorg-minimal-fonts \
 "  
 
+# Any default games we want to ship.
+GAMES = " \
+#  scummvm \
+#  frozen-bubble \
+#  gnome-games \  
+  numptyphysics \
+"
+
 GNOME_APPS = " \
-  epiphany epiphany-extensions \
-  evince \  
-  gnome-games \
   gnome-mplayer \
-  gcalctool \ 
-  gnome-bluetooth \    
+#  gcalctool \ 
+  gnome-keyring gnome-keyring-pam-plugin \
+  gksu \
 "
 
 GNOME_GTK = " \
-#  hicolor-icon-theme \
 #  gnome-icon-theme \
 #  angstrom-gnome-icon-theme-enable \
 "
 
 GSTREAMER = " \
+#  gstreamer-ti \
   gst-ffmpeg \
   gst-omapfb \
-  gst-plugin-pulse \
+#  gst-plugin-pulse \
+  gst-plugin-xvimagesink \
   gst-plugins-base-meta \
-#  gst-plugins-good-meta \
+  gst-plugins-good-meta \
   gst-plugins-bad-meta \
 #  gst-plugins-ugly-meta \
+  gst-plugin-gles \
 "
 
 ICON_THEME = " \
-  tango-icon-theme \
-  tango-icon-theme-enable \
+  hicolor-icon-theme \
+  elementary-icon-theme \
+  elementary-icon-theme-enable \
+"
+
+LAUNCHERS = " \
+#  netbook-launcher-efl \
+  pandora-libpnd-minimenu \
+  pandora-pmenu \
+"
+
+PANDORA = " \
+  pandora-first-run-wizard hsetroot \
+  pandora-scripts \
+  pandora-lcd-state \
+  pandora-wallpaper-official pandora-wallpaper-community \
+  pandora-xfce-defaults \
+  pandora-xmms-defaults xmms \
+#  pandora-midori-defaults midori \
+  libgles2d \
 "
 
 PERL = " \
@@ -88,11 +121,31 @@ PERL = " \
 "
 
 PULSEAUDIO = " \
-  pulseaudio-alsa-wrapper \
-  pulseaudio-esd-wrapper \
-  pulseaudio-module-gconf \
-  libasound-module-ctl-pulse \
-  libasound-module-pcm-pulse \
+#  pulseaudio-alsa-wrapper \
+#  pulseaudio-esd-wrapper \
+#  pulseaudio-module-gconf \
+#  libasound-module-ctl-pulse \
+#  libasound-module-pcm-pulse \
+"
+
+QT_SELECTED = " qt4-x11-free \
+"
+# qt4-x11-free"
+# qt4-x11-free-gles"
+
+#PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
+
+QT_SUPPORT = " \
+  ${QT_SELECTED} \
+  qt4-plugin-imageformat-png \
+  qt4-plugin-imageformat-jpeg \
+  qt4-plugin-imageformat-gif \
+"
+
+# We want all of the Qt metapackage (for dev use) without the demos/examples.
+BAD_RRECOMMENDS += " \
+  ${QT_SELECTED}-demos \
+  ${QT_SELECTED}-examples \
 "
 
 TOTEM = " \
@@ -108,6 +161,12 @@ TOTEM = " \
   totem-plugin-thumbnail \
 "
 
+TOUCHSCREEN = " \
+  gtk-touchscreen-mode-enable \
+  libgtkstylus \
+  xinput-calibrator \
+"
+
 XFCE46_BASE = " \
   xfce4-dev-tools \
   xfwm4 \
@@ -117,6 +176,7 @@ XFCE46_BASE = " \
   xfconf \
   xfdesktop \
   xfce4-panel \
+  xfce4-power-manager \
   \
   gtk-xfce-engine \
   \
@@ -139,8 +199,8 @@ XFCE46_EXTRAS = " \
   xfce4-notifyd \
   xfce4-mixer \
   xfce4-appfinder \
+  xfce4-battery-plugin \
   xfprint \    
-  midori \
   orage \
   squeeze \
   ristretto \
@@ -151,21 +211,20 @@ XFCE46_EXTRAS = " \
 XFCE_THEMES = " \
   xfwm4-theme-daloa \
   xfwm4-theme-moheli \
-  xfwm4-theme-default-4.0 \
-  xfwm4-theme-default-4.2 \
-  xfwm4-theme-default-4.4 \
+#  xfwm4-theme-default-4.0 \
+#  xfwm4-theme-default-4.2 \
+#  xfwm4-theme-default-4.4 \
   xfwm4-theme-kokodi \
-  xfwm4-theme-moheli \
   xfwm4-theme-sassandra \
-  xfwm4-theme-stoneage \
-  xfwm4-theme-therapy \
-  xfwm4-theme-tyrex \
-  xfwm4-theme-wallis \  
+#  xfwm4-theme-stoneage \
+#  xfwm4-theme-therapy \
+#  xfwm4-theme-tyrex \
+#  xfwm4-theme-wallis \  
+  xfwm4-themes \
 "
 
 XSERVER_BASE = " \
   ${XSERVER} \
-  xf86-input-evtouch \
   dbus-x11 \
   desktop-file-utils \
   iso-codes \
@@ -181,6 +240,10 @@ XSERVER_BASE = " \
   xrefresh \
   xset \
   xvinfo \
+  devilspie \
+  encodings \
+  xterm \
+  xmodmap \
 "
 
 RDEPENDS_${PN} = " \
@@ -188,38 +251,38 @@ RDEPENDS_${PN} = " \
   angstrom-x11-base-depends \
   ${ANGSTROM_EXTRA_INSTALL} \
   ${APPS} \
+  ${BLUETOOTH_GUI} \
   ${IM_CLIENT} \
   ${DISPMAN} \
   ${FONTS} \
+  ${GAMES} \  
   ${GNOME_GTK} \
   ${GNOME_APPS} \
   ${GSTREAMER} \
   ${ICON_THEME} \
+  ${LAUNCHERS} \
+  ${PANDORA} \
   ${PERL} \
   ${PULSEAUDIO} \
+  ${QT_SUPPORT} \
   ${TOTEM} \
+  ${TOUCHSCREEN} \
   ${XSERVER_BASE} \
   ${XFCE46_BASE} \
   ${XFCE46_EXTRAS} \
   ${XFCE_THEMES} \
   \
-#      pandora-auto-startx \
-  pandora-first-run-wizard \
-  \
   rxvt-unicode \
-  xst \
-  suspend-desktop \
-  teleport \
+#  xst \
+#  suspend-desktop \
+#  teleport \
   gdk-pixbuf-loader-png \
   gdk-pixbuf-loader-xpm \
   gdk-pixbuf-loader-jpeg \
   pango-module-basic-x \
   pango-module-basic-fc \
   xcursor-transparent-theme \  
-  angstrom-zeroconf-audio \
-  angstrom-led-config \        
-  mime-support \
   xterm xmms \
-  jaaa nmap iperf gnuplot \
-  x11vnc angstrom-x11vnc-xinit \
+  jaaa nmap iperf \
+#  gnuplot \
 "