task-pandora-xfce: Removed openbox. Was working, but didn't make much sense
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index 9e1592c..f809594 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r47"
+PR = "r60"
 
 inherit task
 
@@ -15,9 +15,15 @@ APPS = " \
 #  claws-mail \
   swfdec swfdec-gnome swfdec-mozilla \
 #  gnumeric \   
-  networkmanager network-manager-applet netm-cli 
+  networkmanager network-manager-applet \ 
   vnc x11vnc angstrom-x11vnc-xinit \
   xchat \
+  links-x11 \
+  enchant \
+  aspell \
+  xwininfo \
+  curl \
+  dosfstools \
 #  xournal \
 #  arora \
 "
@@ -98,9 +104,10 @@ PANDORA = " \
   pandora-scripts \
   pandora-wallpaper-official \
   pandora-xfce-defaults \
-  pandora-midori-defaults midori \
+#  pandora-midori-defaults midori \
   libgles2d \
   pandora-misc \
+  pandora-pndstore \
 "
 
 PERL = " \
@@ -127,24 +134,38 @@ PYTHON_LIBS = " \
   gnome-vfs-plugin-ftp \
 "
 
-QT_SELECTED = " qt4-x11-free \
-"
-# qt4-x11-free"
-# qt4-x11-free-gles"
-
-#PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
-
 QT_SUPPORT = " \
-  ${QT_SELECTED} \
-  qt4-plugin-imageformat-jpeg \
-  qt4-plugin-imageformat-gif \
+ libqt3support4 \ 
+ libqtassistantclient4 \ 
+ libqtclucene4 \ 
+ libqtcore4 \ 
+ libqtdbus4 \ 
+ libqtdesigner4 \ 
+ libqtdesignercomponents4 \ 
+ libqtgui4 \ 
+ libqthelp4 \ 
+ libqtnetwork4 \  
+ libqtscript4 \ 
+ libqtscripttools4 \ 
+ libqtsql4 \ 
+ libqtsvg4 \ 
+ libqttest4 \ 
+ libqtwebkit4 \ 
+ libqtxml4 \  
+ qt4-tools \ 
+ qt4-assistant \ 
+ qt4-common \ 
+ qt4-dbus \ 
+ qt4-designer \ 
+ qt4-fonts \ 
+ qt4-linguist \ 
+ qt4-mkspecs \ 
+ qt4-pixeltool \ 
+ qt4-qt3to4 \
+ qt4-plugin-imageformat-jpeg \
+ qt4-plugin-imageformat-gif \
 "
 
-# We want all of the Qt metapackage (for dev use) without the demos/examples.
-BAD_RECOMMENDS += " \
-  qt4-demos \
-  qt4-examples \
-"
 
 TOTEM = " \
 #  totem \
@@ -244,12 +265,14 @@ ADD_LIBS = " \
   libfribidi \
   libgsf \
   libidn \
+  libxslt \
   wv \
   libsamplerate0 \
   glibc-gconv-cp1252 \
   glibc-gconv-ibm850 \
   glibc-gconv-iso8859-15 \
-  
+  gvfsd-sftp \
+  sshfs-fuse \
 " 
 
 RDEPENDS_${PN} = " \