Merge branch 'master' of git://git.openpandora.org/openpandora.oe
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index 890dd93..e4f2054 100755 (executable)
@@ -2,33 +2,44 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r3.1"
+PR = "r25"
 
 inherit task
 
 ANGSTROM_EXTRA_INSTALL ?= ""
 
 APPS = " \
+  avahi-ui \
   abiword \
-  cheese \
   claws-mail \
-  epiphany epiphany-extensions \
   swfdec swfdec-gnome swfdec-mozilla \
-  evince \
-  gcalctool \
-  gedit \
-  gimp \
-  gnome-games \
-  gnome-mplayer \
-  gnumeric \
-  gphoto2 \
-  gthumb \
+#  firefox \
+  gnumeric \   
+#  gimp \
+  networkmanager network-manager-applet \ 
+#  synergy \
+  vnc x11vnc angstrom-x11vnc-xinit \
+  xchat \
+#  xournal \
+  arora \
+"
+
+BLUETOOTH_GUI = " \
+  blueman \
+  gnome-bluetooth \
+"
+
+IM_CLIENT = " \
   pidgin \
-  synergy \
-  vnc \
-  x11vnc angstrom-x11vnc-xinit \
-  xmms \
-  xterm \
+  libpurple-protocol-msn \
+  libpurple-protocol-yahoo \
+  libpurple-protocol-icq \
+  libpurple-protocol-aim \
+"
+
+DISPMAN = " \
+  slim \
+  slim-op-themes \
 "
 
 FONTS = " \
@@ -45,30 +56,169 @@ FONTS = " \
   xorg-minimal-fonts \
 "  
 
+# Any default games we want to ship.
+GAMES = " \
+#  scummvm \
+#  frozen-bubble \
+#  gnome-games \  
+#  numptyphysics \
+"
+
+GNOME_APPS = " \
+#  gnome-mplayer \
+#  gcalctool \ 
+  gnome-keyring gnome-keyring-pam-plugin \
+  gksu \
+"
+
+GNOME_GTK = " \
+#  gnome-icon-theme \
+#  angstrom-gnome-icon-theme-enable \
+"
+
 GSTREAMER = " \
-  gst-ffmpeg \
+#  gstreamer-ti \
+#  gst-ffmpeg \
   gst-omapfb \
-  gst-plugin-pulse \
-  gst-plugins-base-meta \
-  gst-plugins-good-meta \
-  gst-plugins-bad-meta \
+#  gst-plugin-pulse \
+  gst-plugin-xvimagesink \
+#  gst-plugins-base-meta \
+#  gst-plugins-good-meta \
+#  gst-plugins-bad-meta \
 #  gst-plugins-ugly-meta \
+  gst-plugin-gles \
+"
+
+ICON_THEME = " \
+  hicolor-icon-theme \
+  elementary-icon-theme \
+  elementary-icon-theme-enable \
+"
+
+LAUNCHERS = " \
+#  netbook-launcher-efl \
+  pandora-libpnd-minimenu \
+  pandora-pmenu \
+"
+
+PANDORA = " \
+  pandora-first-run-wizard hsetroot \
+  pandora-scripts \
+  pandora-wallpaper-official pandora-wallpaper-community \
+  pandora-xfce-defaults \
+  pandora-midori-defaults midori \
+  libgles2d \
+  pandora-misc \
 "
 
 PERL = " \
   perl \
-#  task-perl-module-all \
-#  libnet-dbus-perl \
+  task-perl-module-all \
+  libnet-dbus-perl \
   libxml-parser-perl \
   libxml-twig-perl \
 "
 
 PULSEAUDIO = " \
-  pulseaudio-alsa-wrapper \
-  pulseaudio-esd-wrapper \
-  pulseaudio-module-gconf \
-  libasound-module-ctl-pulse \
-  libasound-module-pcm-pulse \
+#  pulseaudio-alsa-wrapper \
+#  pulseaudio-esd-wrapper \
+#  pulseaudio-module-gconf \
+#  libasound-module-ctl-pulse \
+#  libasound-module-pcm-pulse \
+"
+
+QT_SELECTED = " qt4-x11-free \
+"
+# qt4-x11-free"
+# qt4-x11-free-gles"
+
+#PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
+
+QT_SUPPORT = " \
+  ${QT_SELECTED} \
+  qt4-plugin-imageformat-jpeg \
+  qt4-plugin-imageformat-gif \
+"
+
+# We want all of the Qt metapackage (for dev use) without the demos/examples.
+BAD_RRECOMMENDS += " \
+  ${QT_SELECTED}-demos \
+  ${QT_SELECTED}-examples \
+"
+
+TOTEM = " \
+#  totem \
+#  totem-browser-plugin \
+#  totem-plugin-bemused \
+#  totem-plugin-gromit \
+#  totem-plugin-media-player-keys \
+#  totem-plugin-ontop \
+#  totem-plugin-properties \
+#  totem-plugin-screensaver \
+#  totem-plugin-skipto \
+#  totem-plugin-thumbnail \
+"
+
+TOUCHSCREEN = " \
+  gtk-touchscreen-mode-enable \
+  libgtkstylus \
+  xinput-calibrator \
+"
+
+XFCE46_BASE = " \
+  xfce4-dev-tools \
+  xfwm4 \
+  xfwm4-theme-default \
+  xfce-utils \  
+  xfce4-session \     
+  xfconf \
+  xfdesktop \
+  xfce4-panel \
+  xfce4-power-manager \
+  \
+  gtk-xfce-engine \
+  \
+  xfce4-panel-plugin-actions \
+  xfce4-panel-plugin-clock \
+  xfce4-panel-plugin-iconbox \
+  xfce4-panel-plugin-launcher \
+  xfce4-panel-plugin-pager \
+  xfce4-panel-plugin-separator \
+  xfce4-panel-plugin-showdesktop \
+  xfce4-panel-plugin-systray \
+  xfce4-panel-plugin-tasklist \
+  xfce4-panel-plugin-windowlist \   
+  xfce4-settings \
+  xfce-terminal \
+  thunar \
+"
+
+XFCE46_EXTRAS = " \
+  xfce4-notifyd \
+  xfce4-mixer \
+  xfce4-appfinder \
+  xfce4-battery-plugin \
+  xfprint \    
+  orage \
+  squeeze \
+  ristretto \
+  mousepad \ 
+  gigolo \
+"
+
+XFCE_THEMES = " \
+  xfwm4-theme-daloa \
+  xfwm4-theme-moheli \
+#  xfwm4-theme-default-4.0 \
+#  xfwm4-theme-default-4.2 \
+#  xfwm4-theme-default-4.4 \
+  xfwm4-theme-kokodi \
+  xfwm4-theme-sassandra \
+#  xfwm4-theme-stoneage \
+#  xfwm4-theme-therapy \
+#  xfwm4-theme-tyrex \
+#  xfwm4-theme-wallis \  
+  xfwm4-themes \
 "
 
 XSERVER_BASE = " \
@@ -79,7 +229,7 @@ XSERVER_BASE = " \
   mime-support \
   notification-daemon inotify-tools \
   xauth \
-#  xdg-utils \
+  xdg-utils \
   xhost \
   xinetd \
   xinit \
@@ -88,60 +238,49 @@ XSERVER_BASE = " \
   xrefresh \
   xset \
   xvinfo \
+  devilspie \
+  encodings \
+  xterm \
+  xmodmap \
 "
 
-RDEPENDS_${PN} = "\
+RDEPENDS_${PN} = " \
   task-pandora-core \
+  angstrom-x11-base-depends \
   ${ANGSTROM_EXTRA_INSTALL} \
   ${APPS} \
+  ${BLUETOOTH_GUI} \
+  ${IM_CLIENT} \
+  ${DISPMAN} \
   ${FONTS} \
+  ${GAMES} \  
+  ${GNOME_GTK} \
+  ${GNOME_APPS} \
   ${GSTREAMER} \
+  ${ICON_THEME} \
+  ${LAUNCHERS} \
+  ${PANDORA} \
   ${PERL} \
   ${PULSEAUDIO} \
+  ${QT_SUPPORT} \
+  ${TOTEM} \
+  ${TOUCHSCREEN} \
   ${XSERVER_BASE} \
-       \
-       angstrom-x11-base-depends \
-       \
-#      pandora-auto-startx \
-#      pandora-first-run-wizard \
-       \
-       task-xfce46-base \
-       task-xfce46-extras \    
-       \
-#      gnome-packagekit \
-       \
-       rxvt-unicode \
-       xkbd \
-       xst \
-       xhost \
-       xrdb \
-       libgtkstylus \
-       suspend-desktop \
-       teleport \
-       xauth \
-       gdk-pixbuf-loader-png \
-       gdk-pixbuf-loader-xpm \
-       gdk-pixbuf-loader-jpeg \
-       pango-module-basic-x \
-       pango-module-basic-fc \
-       gpe-theme-clearlooks \
-       xcursor-transparent-theme \     
-       angstrom-zeroconf-audio \
-       angstrom-led-config \   
-       mime-support \
-       xterm xmms \
-       firefox \
-       hicolor-icon-theme gnome-icon-theme \
-       jaaa nmap iperf gnuplot \
-       abiword \
-       gnumeric \
-       gimp \
-       pidgin \
-       gnome-games \
-       stalonetray \
-       synergy \
-       x11vnc angstrom-x11vnc-xinit \
-       angstrom-gnome-icon-theme-enable \
-       networkmanager network-manager-applet \
-       gnome-bluetooth \
+  ${XFCE46_BASE} \
+  ${XFCE46_EXTRAS} \
+  ${XFCE_THEMES} \
+  \
+  rxvt-unicode \
+#  xst \
+#  suspend-desktop \
+#  teleport \
+  gdk-pixbuf-loader-png \
+  gdk-pixbuf-loader-xpm \
+  gdk-pixbuf-loader-jpeg \
+  pango-module-basic-x \
+  pango-module-basic-fc \
+  xcursor-transparent-theme \  
+  xterm xmms \
+  jaaa nmap iperf \
+#  gnuplot \
 "