task-pandora: Sync in local changes to bump PR's and add more libs to the toolchain.
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index 3ea1757..d78128f 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r9"
+PR = "r36"
 
 inherit task
 
@@ -11,20 +11,18 @@ ANGSTROM_EXTRA_INSTALL ?= ""
 APPS = " \
   avahi-ui \
   abiword \
+  evince \
   claws-mail \
   swfdec swfdec-gnome swfdec-mozilla \
-  firefox \
   gnumeric \   
-#  gimp \
   networkmanager network-manager-applet \ 
-#  synergy \
   vnc x11vnc angstrom-x11vnc-xinit \
   xchat \
-  xournal \
+#  xournal \
+  arora \
 "
 
 BLUETOOTH_GUI = " \
-  blueman \
   gnome-bluetooth \
 "
 
@@ -60,20 +58,16 @@ GAMES = " \
 #  scummvm \
 #  frozen-bubble \
 #  gnome-games \  
+#  numptyphysics \
 "
 
 GNOME_APPS = " \
-  gnome-mplayer \
+#  gnome-mplayer \
 #  gcalctool \ 
   gnome-keyring gnome-keyring-pam-plugin \
   gksu \
 "
 
-GNOME_GTK = " \
-#  gnome-icon-theme \
-#  angstrom-gnome-icon-theme-enable \
-"
-
 GSTREAMER = " \
 #  gstreamer-ti \
   gst-ffmpeg \
@@ -81,7 +75,8 @@ GSTREAMER = " \
 #  gst-plugin-pulse \
   gst-plugin-xvimagesink \
   gst-plugins-base-meta \
-  gst-plugins-good-meta gst-plugins-bad-meta \
+#  gst-plugins-good-meta \
+#  gst-plugins-bad-meta \
 #  gst-plugins-ugly-meta \
   gst-plugin-gles \
 "
@@ -94,6 +89,8 @@ ICON_THEME = " \
 
 LAUNCHERS = " \
   netbook-launcher-efl \
+  pandora-libpnd-minimenu \
+  pandora-pmenu \
 "
 
 PANDORA = " \
@@ -101,11 +98,9 @@ PANDORA = " \
   pandora-scripts \
   pandora-wallpaper-official pandora-wallpaper-community \
   pandora-xfce-defaults \
-  pandora-xmms-defaults xmms \
   pandora-midori-defaults midori \
-  pandora-libpnd-minimenu \
-  pandora-pmenu \
   libgles2d \
+  pandora-misc \
 "
 
 PERL = " \
@@ -124,11 +119,25 @@ PULSEAUDIO = " \
 #  libasound-module-pcm-pulse \
 "
 
-QT_SELECTED = "qt4-x11-free-gles"
-#  qt4-x11-free \
+PYTHON_LIBS = " \
+  python-shell \
+  python-pygtk \
+  python-pycairo \
+  gnome-vfs-plugin-http \
+  gnome-vfs-plugin-ftp \
+"
+
+QT_SELECTED = " qt4-x11-free \
+"
+# qt4-x11-free"
+# qt4-x11-free-gles"
+
+#PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
 
 QT_SUPPORT = " \
   ${QT_SELECTED} \
+  qt4-plugin-imageformat-jpeg \
+  qt4-plugin-imageformat-gif \
 "
 
 # We want all of the Qt metapackage (for dev use) without the demos/examples.
@@ -138,22 +147,22 @@ BAD_RRECOMMENDS += " \
 "
 
 TOTEM = " \
-  totem \
-  totem-browser-plugin \
-  totem-plugin-bemused \
-  totem-plugin-gromit \
-  totem-plugin-media-player-keys \
-  totem-plugin-ontop \
-  totem-plugin-properties \
-  totem-plugin-screensaver \
-  totem-plugin-skipto \
-  totem-plugin-thumbnail \
+#  totem \
+#  totem-browser-plugin \
+#  totem-plugin-bemused \
+#  totem-plugin-gromit \
+#  totem-plugin-media-player-keys \
+#  totem-plugin-ontop \
+#  totem-plugin-properties \
+#  totem-plugin-screensaver \
+#  totem-plugin-skipto \
+#  totem-plugin-thumbnail \
 "
 
 TOUCHSCREEN = " \
   gtk-touchscreen-mode-enable \
   libgtkstylus \
-  xinput-calibrator \
+#  xinput-calibrator \
 "
 
 XFCE46_BASE = " \
@@ -200,15 +209,8 @@ XFCE46_EXTRAS = " \
 XFCE_THEMES = " \
   xfwm4-theme-daloa \
   xfwm4-theme-moheli \
-#  xfwm4-theme-default-4.0 \
-#  xfwm4-theme-default-4.2 \
-#  xfwm4-theme-default-4.4 \
   xfwm4-theme-kokodi \
   xfwm4-theme-sassandra \
-#  xfwm4-theme-stoneage \
-#  xfwm4-theme-therapy \
-#  xfwm4-theme-tyrex \
-#  xfwm4-theme-wallis \  
   xfwm4-themes \
 "
 
@@ -245,7 +247,6 @@ RDEPENDS_${PN} = " \
   ${DISPMAN} \
   ${FONTS} \
   ${GAMES} \  
-  ${GNOME_GTK} \
   ${GNOME_APPS} \
   ${GSTREAMER} \
   ${ICON_THEME} \
@@ -253,6 +254,7 @@ RDEPENDS_${PN} = " \
   ${PANDORA} \
   ${PERL} \
   ${PULSEAUDIO} \
+  ${PYTHON_LIBS} \
   ${QT_SUPPORT} \
   ${TOTEM} \
   ${TOUCHSCREEN} \
@@ -271,7 +273,7 @@ RDEPENDS_${PN} = " \
   pango-module-basic-x \
   pango-module-basic-fc \
   xcursor-transparent-theme \  
-  xterm xmms \
+  xterm \
   jaaa nmap iperf \
 #  gnuplot \
 "