task-pandora-xfce.bb: Added OpenBox and some needed programs for Gigolo
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index 5b49a6c..c6a0773 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r2"
+PR = "r59"
 
 inherit task
 
@@ -10,31 +10,34 @@ ANGSTROM_EXTRA_INSTALL ?= ""
 
 APPS = " \
   avahi-ui \
-  abiword \
-  claws-mail \
+#  abiword \
+  evince \
+#  claws-mail \
   swfdec swfdec-gnome swfdec-mozilla \
-  firefox \
-  gnumeric \   
-  gimp \
+#  gnumeric \   
   networkmanager network-manager-applet \ 
-  synergy \
-  vnc \
-  x11vnc angstrom-x11vnc-xinit \
-  xterm \
+  vnc x11vnc angstrom-x11vnc-xinit \
   xchat \
+  links-x11 \
+  enchant \
+  aspell \
+  xwininfo \
+  curl \
+  dosfstools \
+#  xournal \
+#  arora \
 "
 
 BLUETOOTH_GUI = " \
-#  blueman \
   gnome-bluetooth \
 "
 
 IM_CLIENT = " \
-  pidgin \
-  libpurple-protocol-msn \
-  libpurple-protocol-yahoo \
-  libpurple-protocol-icq \
-  libpurple-protocol-aim \
+#  pidgin \
+#  libpurple-protocol-msn \
+#  libpurple-protocol-yahoo \
+#  libpurple-protocol-icq \
+#  libpurple-protocol-aim \
 "
 
 DISPMAN = " \
@@ -58,45 +61,53 @@ FONTS = " \
 
 # Any default games we want to ship.
 GAMES = " \
-  scummvm \
+#  scummvm \
+#  frozen-bubble \
+#  gnome-games \  
+#  numptyphysics \
 "
 
 GNOME_APPS = " \
-#  epiphany epiphany-extensions \
-#  evince \  
-  gnome-games \
-  gnome-mplayer \
+#  gnome-mplayer \
   gcalctool \ 
   gnome-keyring gnome-keyring-pam-plugin \
-"
-
-GNOME_GTK = " \
-#  hicolor-icon-theme \
-#  gnome-icon-theme \
-#  angstrom-gnome-icon-theme-enable \
+  gksu \
 "
 
 GSTREAMER = " \
+#  gstreamer-ti \
   gst-ffmpeg \
   gst-omapfb \
-  gst-plugin-pulse \
+#  gst-plugin-pulse \
+  gst-plugin-xvimagesink \
   gst-plugins-base-meta \
 #  gst-plugins-good-meta \
-  gst-plugins-bad-meta \
+#  gst-plugins-bad-meta \
 #  gst-plugins-ugly-meta \
+  gst-plugin-gles \
 "
 
 ICON_THEME = " \
+  hicolor-icon-theme \
   elementary-icon-theme \
   elementary-icon-theme-enable \
 "
 
+LAUNCHERS = " \
+#  netbook-launcher-efl \
+  pandora-libpnd-minimenu \
+#  pandora-pmenu \
+"
+
 PANDORA = " \
   pandora-first-run-wizard hsetroot \
   pandora-scripts \
-  pandora-wallpaper-official pandora-wallpaper-community \
+  pandora-wallpaper-official \
   pandora-xfce-defaults \
-  pandora-xmms-defaults xmms \
+#  pandora-midori-defaults midori \
+  libgles2d \
+  pandora-misc \
+  pandora-pndstore \
 "
 
 PERL = " \
@@ -108,35 +119,71 @@ PERL = " \
 "
 
 PULSEAUDIO = " \
-  pulseaudio-alsa-wrapper \
-  pulseaudio-esd-wrapper \
-  pulseaudio-module-gconf \
-  libasound-module-ctl-pulse \
-  libasound-module-pcm-pulse \
+#  pulseaudio-alsa-wrapper \
+#  pulseaudio-esd-wrapper \
+#  pulseaudio-module-gconf \
+#  libasound-module-ctl-pulse \
+#  libasound-module-pcm-pulse \
+"
+
+PYTHON_LIBS = " \
+  python-shell \
+  python-pygtk \
+  python-pycairo \
+  gnome-vfs-plugin-http \
+  gnome-vfs-plugin-ftp \
 "
 
 QT_SUPPORT = " \
-  qt4-x11-free \
-#  qt4-x11-free-gles \
+ libqt3support4 \ 
+ libqtassistantclient4 \ 
+ libqtclucene4 \ 
+ libqtcore4 \ 
+ libqtdbus4 \ 
+ libqtdesigner4 \ 
+ libqtdesignercomponents4 \ 
+ libqtgui4 \ 
+ libqthelp4 \ 
+ libqtnetwork4 \  
+ libqtscript4 \ 
+ libqtscripttools4 \ 
+ libqtsql4 \ 
+ libqtsvg4 \ 
+ libqttest4 \ 
+ libqtwebkit4 \ 
+ libqtxml4 \  
+ qt4-tools \ 
+ qt4-assistant \ 
+ qt4-common \ 
+ qt4-dbus \ 
+ qt4-designer \ 
+ qt4-fonts \ 
+ qt4-linguist \ 
+ qt4-mkspecs \ 
+ qt4-pixeltool \ 
+ qt4-qt3to4 \
+ qt4-plugin-imageformat-jpeg \
+ qt4-plugin-imageformat-gif \
 "
 
+
 TOTEM = " \
-  totem \
-  totem-browser-plugin \
-  totem-plugin-bemused \
-  totem-plugin-gromit \
-  totem-plugin-media-player-keys \
-  totem-plugin-ontop \
-  totem-plugin-properties \
-  totem-plugin-screensaver \
-  totem-plugin-skipto \
-  totem-plugin-thumbnail \
+#  totem \
+#  totem-browser-plugin \
+#  totem-plugin-bemused \
+#  totem-plugin-gromit \
+#  totem-plugin-media-player-keys \
+#  totem-plugin-ontop \
+#  totem-plugin-properties \
+#  totem-plugin-screensaver \
+#  totem-plugin-skipto \
+#  totem-plugin-thumbnail \
 "
 
 TOUCHSCREEN = " \
-  xf86-input-tslib \
   gtk-touchscreen-mode-enable \
   libgtkstylus \
+#  xinput-calibrator \
 "
 
 XFCE46_BASE = " \
@@ -148,6 +195,7 @@ XFCE46_BASE = " \
   xfconf \
   xfdesktop \
   xfce4-panel \
+  xfce4-power-manager \
   \
   gtk-xfce-engine \
   \
@@ -170,28 +218,23 @@ XFCE46_EXTRAS = " \
   xfce4-notifyd \
   xfce4-mixer \
   xfce4-appfinder \
+  xfce4-battery-plugin \
   xfprint \    
-  midori \
   orage \
   squeeze \
   ristretto \
   mousepad \ 
   gigolo \
+  xdotool \
+  openbox \
 "
 
 XFCE_THEMES = " \
   xfwm4-theme-daloa \
   xfwm4-theme-moheli \
-  xfwm4-theme-default-4.0 \
-  xfwm4-theme-default-4.2 \
-  xfwm4-theme-default-4.4 \
   xfwm4-theme-kokodi \
-  xfwm4-theme-moheli \
   xfwm4-theme-sassandra \
-  xfwm4-theme-stoneage \
-  xfwm4-theme-therapy \
-  xfwm4-theme-tyrex \
-  xfwm4-theme-wallis \  
+  xfwm4-themes \
 "
 
 XSERVER_BASE = " \
@@ -212,8 +255,27 @@ XSERVER_BASE = " \
   xset \
   xvinfo \
   devilspie \
+  encodings \
+  xterm \
+  xmodmap \
 "
 
+ADD_LIBS = " \
+  libbonobo \
+  libetpan \
+  libfribidi \
+  libgsf \
+  libidn \
+  libxslt \
+  wv \
+  libsamplerate0 \
+  glibc-gconv-cp1252 \
+  glibc-gconv-ibm850 \
+  glibc-gconv-iso8859-15 \
+  gvfsd-sftp
+  sshfs-fuse
+" 
+
 RDEPENDS_${PN} = " \
   task-pandora-core \
   angstrom-x11-base-depends \
@@ -224,13 +286,14 @@ RDEPENDS_${PN} = " \
   ${DISPMAN} \
   ${FONTS} \
   ${GAMES} \  
-  ${GNOME_GTK} \
   ${GNOME_APPS} \
   ${GSTREAMER} \
   ${ICON_THEME} \
+  ${LAUNCHERS} \
   ${PANDORA} \
   ${PERL} \
   ${PULSEAUDIO} \
+  ${PYTHON_LIBS} \
   ${QT_SUPPORT} \
   ${TOTEM} \
   ${TOUCHSCREEN} \
@@ -238,19 +301,19 @@ RDEPENDS_${PN} = " \
   ${XFCE46_BASE} \
   ${XFCE46_EXTRAS} \
   ${XFCE_THEMES} \
+  ${ADD_LIBS} \
   \
   rxvt-unicode \
-  xst \
-  suspend-desktop \
-  teleport \
+#  xst \
+#  suspend-desktop \
+#  teleport \
   gdk-pixbuf-loader-png \
   gdk-pixbuf-loader-xpm \
   gdk-pixbuf-loader-jpeg \
   pango-module-basic-x \
   pango-module-basic-fc \
   xcursor-transparent-theme \  
-  mime-support \
-  xterm xmms \
-  jaaa nmap iperf gnuplot \
-  x11vnc angstrom-x11vnc-xinit \
+  xterm \
+  jaaa nmap iperf \
+#  gnuplot \
 "