task-pandora-xfce.bb: Added openvpn and networkmanager-openvpn. Bumped recipe.
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index 8c468c6..c2b8d1c 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r40"
+PR = "r62"
 
 inherit task
 
@@ -17,9 +17,16 @@ APPS = " \
 #  gnumeric \   
   networkmanager network-manager-applet \ 
   vnc x11vnc angstrom-x11vnc-xinit \
+  openvpn networkmanager-openvpn \
   xchat \
+  links-x11 \
+  enchant \
+  aspell \
+  xwininfo \
+  curl \
+  dosfstools \
 #  xournal \
-  arora \
+#  arora \
 "
 
 BLUETOOTH_GUI = " \
@@ -90,17 +97,18 @@ ICON_THEME = " \
 LAUNCHERS = " \
 #  netbook-launcher-efl \
   pandora-libpnd-minimenu \
-  pandora-pmenu \
+#  pandora-pmenu \
 "
 
 PANDORA = " \
   pandora-first-run-wizard hsetroot \
   pandora-scripts \
-  pandora-wallpaper-official pandora-wallpaper-community \
+  pandora-wallpaper-official \
   pandora-xfce-defaults \
-  pandora-midori-defaults midori \
+#  pandora-midori-defaults midori \
   libgles2d \
   pandora-misc \
+  pandora-pndstore \
 "
 
 PERL = " \
@@ -127,24 +135,38 @@ PYTHON_LIBS = " \
   gnome-vfs-plugin-ftp \
 "
 
-QT_SELECTED = " qt4-x11-free \
-"
-# qt4-x11-free"
-# qt4-x11-free-gles"
-
-#PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
-
 QT_SUPPORT = " \
-  ${QT_SELECTED} \
-  qt4-plugin-imageformat-jpeg \
-  qt4-plugin-imageformat-gif \
+ libqt3support4 \ 
+ libqtassistantclient4 \ 
+ libqtclucene4 \ 
+ libqtcore4 \ 
+ libqtdbus4 \ 
+ libqtdesigner4 \ 
+ libqtdesignercomponents4 \ 
+ libqtgui4 \ 
+ libqthelp4 \ 
+ libqtnetwork4 \  
+ libqtscript4 \ 
+ libqtscripttools4 \ 
+ libqtsql4 \ 
+ libqtsvg4 \ 
+ libqttest4 \ 
+ libqtwebkit4 \ 
+ libqtxml4 \  
+ qt4-tools \ 
+ qt4-assistant \ 
+ qt4-common \ 
+ qt4-dbus \ 
+ qt4-designer \ 
+ qt4-fonts \ 
+ qt4-linguist \ 
+ qt4-mkspecs \ 
+ qt4-pixeltool \ 
+ qt4-qt3to4 \
+ qt4-plugin-imageformat-jpeg \
+ qt4-plugin-imageformat-gif \
 "
 
-# We want all of the Qt metapackage (for dev use) without the demos/examples.
-BAD_RRECOMMENDS += " \
-  ${QT_SELECTED}-demos \
-  ${QT_SELECTED}-examples \
-"
 
 TOTEM = " \
 #  totem \
@@ -204,6 +226,7 @@ XFCE46_EXTRAS = " \
   ristretto \
   mousepad \ 
   gigolo \
+  xdotool \
 "
 
 XFCE_THEMES = " \
@@ -243,8 +266,16 @@ ADD_LIBS = " \
   libfribidi \
   libgsf \
   libidn \
+  libxslt \
   wv \
-  libsamplerate \
+  libsamplerate0 \
+  glibc-gconv-cp1252 \
+  glibc-gconv-ibm850 \
+  glibc-gconv-iso8859-15 \
+  gvfsd-sftp \
+  sshfs-fuse \
+  rtl8712-module \
+  rtl8192u-module \
 " 
 
 RDEPENDS_${PN} = " \