Removed qt4-plugin-phonon-backend-gstreamer - pulled in too many
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index a8b9815..b3e6925 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r28"
+PR = "r35"
 
 inherit task
 
@@ -11,6 +11,7 @@ ANGSTROM_EXTRA_INSTALL ?= ""
 APPS = " \
   avahi-ui \
   abiword \
+  evince \
   claws-mail \
   swfdec swfdec-gnome swfdec-mozilla \
 #  firefox \
@@ -77,11 +78,11 @@ GNOME_GTK = " \
 
 GSTREAMER = " \
 #  gstreamer-ti \
-#  gst-ffmpeg \
+  gst-ffmpeg \
   gst-omapfb \
 #  gst-plugin-pulse \
   gst-plugin-xvimagesink \
-#  gst-plugins-base-meta \
+  gst-plugins-base-meta \
 #  gst-plugins-good-meta \
 #  gst-plugins-bad-meta \
 #  gst-plugins-ugly-meta \
@@ -126,7 +127,15 @@ PULSEAUDIO = " \
 #  libasound-module-pcm-pulse \
 "
 
-QT_SELECTED = " qt4-x11-free \
+PYTHON_LIBS = " \
+  python-shell \
+  python-pygtk \
+  python-pycairo \
+  gnome-vfs-plugin-http \
+  gnome-vfs-plugin-ftp \
+"
+
+QT_SELECTED = " qt4-x11-free-gles \
 "
 # qt4-x11-free"
 # qt4-x11-free-gles"
@@ -254,6 +263,7 @@ RDEPENDS_${PN} = " \
   ${PANDORA} \
   ${PERL} \
   ${PULSEAUDIO} \
+  ${PYTHON_LIBS} \
   ${QT_SUPPORT} \
   ${TOTEM} \
   ${TOUCHSCREEN} \