Back to: qt4-x11-free since qt4-x11-free-gles lead to an error.
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index ac10305..92e7aee 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r22"
+PR = "r36"
 
 inherit task
 
@@ -11,6 +11,7 @@ ANGSTROM_EXTRA_INSTALL ?= ""
 APPS = " \
   avahi-ui \
   abiword \
+  evince \
   claws-mail \
   swfdec swfdec-gnome swfdec-mozilla \
 #  firefox \
@@ -25,7 +26,6 @@ APPS = " \
 "
 
 BLUETOOTH_GUI = " \
-  blueman \
   gnome-bluetooth \
 "
 
@@ -61,11 +61,11 @@ GAMES = " \
 #  scummvm \
 #  frozen-bubble \
 #  gnome-games \  
-  numptyphysics \
+#  numptyphysics \
 "
 
 GNOME_APPS = " \
-  gnome-mplayer \
+#  gnome-mplayer \
 #  gcalctool \ 
   gnome-keyring gnome-keyring-pam-plugin \
   gksu \
@@ -83,8 +83,8 @@ GSTREAMER = " \
 #  gst-plugin-pulse \
   gst-plugin-xvimagesink \
   gst-plugins-base-meta \
-  gst-plugins-good-meta \
-  gst-plugins-bad-meta \
+#  gst-plugins-good-meta \
+#  gst-plugins-bad-meta \
 #  gst-plugins-ugly-meta \
   gst-plugin-gles \
 "
@@ -104,12 +104,11 @@ LAUNCHERS = " \
 PANDORA = " \
   pandora-first-run-wizard hsetroot \
   pandora-scripts \
-  pandora-lcd-state \
   pandora-wallpaper-official pandora-wallpaper-community \
   pandora-xfce-defaults \
-  pandora-xmms-defaults xmms \
-#  pandora-midori-defaults midori \
+  pandora-midori-defaults midori \
   libgles2d \
+  pandora-misc \
 "
 
 PERL = " \
@@ -128,6 +127,14 @@ PULSEAUDIO = " \
 #  libasound-module-pcm-pulse \
 "
 
+PYTHON_LIBS = " \
+  python-shell \
+  python-pygtk \
+  python-pycairo \
+  gnome-vfs-plugin-http \
+  gnome-vfs-plugin-ftp \
+"
+
 QT_SELECTED = " qt4-x11-free \
 "
 # qt4-x11-free"
@@ -148,22 +155,22 @@ BAD_RRECOMMENDS += " \
 "
 
 TOTEM = " \
-  totem \
-  totem-browser-plugin \
-  totem-plugin-bemused \
-  totem-plugin-gromit \
-  totem-plugin-media-player-keys \
-  totem-plugin-ontop \
-  totem-plugin-properties \
-  totem-plugin-screensaver \
-  totem-plugin-skipto \
-  totem-plugin-thumbnail \
+#  totem \
+#  totem-browser-plugin \
+#  totem-plugin-bemused \
+#  totem-plugin-gromit \
+#  totem-plugin-media-player-keys \
+#  totem-plugin-ontop \
+#  totem-plugin-properties \
+#  totem-plugin-screensaver \
+#  totem-plugin-skipto \
+#  totem-plugin-thumbnail \
 "
 
 TOUCHSCREEN = " \
   gtk-touchscreen-mode-enable \
   libgtkstylus \
-  xinput-calibrator \
+#  xinput-calibrator \
 "
 
 XFCE46_BASE = " \
@@ -210,15 +217,8 @@ XFCE46_EXTRAS = " \
 XFCE_THEMES = " \
   xfwm4-theme-daloa \
   xfwm4-theme-moheli \
-#  xfwm4-theme-default-4.0 \
-#  xfwm4-theme-default-4.2 \
-#  xfwm4-theme-default-4.4 \
   xfwm4-theme-kokodi \
   xfwm4-theme-sassandra \
-#  xfwm4-theme-stoneage \
-#  xfwm4-theme-therapy \
-#  xfwm4-theme-tyrex \
-#  xfwm4-theme-wallis \  
   xfwm4-themes \
 "
 
@@ -263,6 +263,7 @@ RDEPENDS_${PN} = " \
   ${PANDORA} \
   ${PERL} \
   ${PULSEAUDIO} \
+  ${PYTHON_LIBS} \
   ${QT_SUPPORT} \
   ${TOTEM} \
   ${TOUCHSCREEN} \
@@ -281,7 +282,7 @@ RDEPENDS_${PN} = " \
   pango-module-basic-x \
   pango-module-basic-fc \
   xcursor-transparent-theme \  
-  xterm xmms \
+  xterm \
   jaaa nmap iperf \
 #  gnuplot \
 "