task-pandora-xfce: Remove netbook-launcher from the current image.
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index 7f3fae4..84d3d82 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r24"
+PR = "r37"
 
 inherit task
 
@@ -11,13 +11,11 @@ ANGSTROM_EXTRA_INSTALL ?= ""
 APPS = " \
   avahi-ui \
   abiword \
+  evince \
   claws-mail \
   swfdec swfdec-gnome swfdec-mozilla \
-#  firefox \
   gnumeric \   
-#  gimp \
   networkmanager network-manager-applet \ 
-#  synergy \
   vnc x11vnc angstrom-x11vnc-xinit \
   xchat \
 #  xournal \
@@ -25,7 +23,6 @@ APPS = " \
 "
 
 BLUETOOTH_GUI = " \
-  blueman \
   gnome-bluetooth \
 "
 
@@ -71,18 +68,13 @@ GNOME_APPS = " \
   gksu \
 "
 
-GNOME_GTK = " \
-#  gnome-icon-theme \
-#  angstrom-gnome-icon-theme-enable \
-"
-
 GSTREAMER = " \
 #  gstreamer-ti \
-#  gst-ffmpeg \
+  gst-ffmpeg \
   gst-omapfb \
 #  gst-plugin-pulse \
   gst-plugin-xvimagesink \
-#  gst-plugins-base-meta \
+  gst-plugins-base-meta \
 #  gst-plugins-good-meta \
 #  gst-plugins-bad-meta \
 #  gst-plugins-ugly-meta \
@@ -106,7 +98,6 @@ PANDORA = " \
   pandora-scripts \
   pandora-wallpaper-official pandora-wallpaper-community \
   pandora-xfce-defaults \
-  pandora-xmms-defaults xmms \
   pandora-midori-defaults midori \
   libgles2d \
   pandora-misc \
@@ -128,6 +119,14 @@ PULSEAUDIO = " \
 #  libasound-module-pcm-pulse \
 "
 
+PYTHON_LIBS = " \
+  python-shell \
+  python-pygtk \
+  python-pycairo \
+  gnome-vfs-plugin-http \
+  gnome-vfs-plugin-ftp \
+"
+
 QT_SELECTED = " qt4-x11-free \
 "
 # qt4-x11-free"
@@ -163,7 +162,7 @@ TOTEM = " \
 TOUCHSCREEN = " \
   gtk-touchscreen-mode-enable \
   libgtkstylus \
-  xinput-calibrator \
+#  xinput-calibrator \
 "
 
 XFCE46_BASE = " \
@@ -210,15 +209,8 @@ XFCE46_EXTRAS = " \
 XFCE_THEMES = " \
   xfwm4-theme-daloa \
   xfwm4-theme-moheli \
-#  xfwm4-theme-default-4.0 \
-#  xfwm4-theme-default-4.2 \
-#  xfwm4-theme-default-4.4 \
   xfwm4-theme-kokodi \
   xfwm4-theme-sassandra \
-#  xfwm4-theme-stoneage \
-#  xfwm4-theme-therapy \
-#  xfwm4-theme-tyrex \
-#  xfwm4-theme-wallis \  
   xfwm4-themes \
 "
 
@@ -255,7 +247,6 @@ RDEPENDS_${PN} = " \
   ${DISPMAN} \
   ${FONTS} \
   ${GAMES} \  
-  ${GNOME_GTK} \
   ${GNOME_APPS} \
   ${GSTREAMER} \
   ${ICON_THEME} \
@@ -263,6 +254,7 @@ RDEPENDS_${PN} = " \
   ${PANDORA} \
   ${PERL} \
   ${PULSEAUDIO} \
+  ${PYTHON_LIBS} \
   ${QT_SUPPORT} \
   ${TOTEM} \
   ${TOUCHSCREEN} \
@@ -281,7 +273,7 @@ RDEPENDS_${PN} = " \
   pango-module-basic-x \
   pango-module-basic-fc \
   xcursor-transparent-theme \  
-  xterm xmms \
+  xterm \
   jaaa nmap iperf \
 #  gnuplot \
 "