task-pandora-xfce.bb: Added configtray-wifi
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index d98c305..632b75b 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r30"
+PR = "r72"
 
 inherit task
 
@@ -10,18 +10,25 @@ ANGSTROM_EXTRA_INSTALL ?= ""
 
 APPS = " \
   avahi-ui \
-  abiword \
-  claws-mail \
+#  abiword \
+  evince \
+#  claws-mail \
   swfdec swfdec-gnome swfdec-mozilla \
-#  firefox \
-  gnumeric \   
-#  gimp \
+#  gnumeric \   
   networkmanager network-manager-applet \ 
-#  synergy \
   vnc x11vnc angstrom-x11vnc-xinit \
+  openvpn networkmanager-openvpn \
+  modemmanager \
   xchat \
+  links-x11 \
+  enchant \
+  aspell \
+  xwininfo \
+  curl \
+  dosfstools \
+  netkit-ftp \
 #  xournal \
-  arora \
+#  arora \
 "
 
 BLUETOOTH_GUI = " \
@@ -29,11 +36,11 @@ BLUETOOTH_GUI = " \
 "
 
 IM_CLIENT = " \
-  pidgin \
-  libpurple-protocol-msn \
-  libpurple-protocol-yahoo \
-  libpurple-protocol-icq \
-  libpurple-protocol-aim \
+#  pidgin \
+#  libpurple-protocol-msn \
+#  libpurple-protocol-yahoo \
+#  libpurple-protocol-icq \
+#  libpurple-protocol-aim \
 "
 
 DISPMAN = " \
@@ -65,16 +72,11 @@ GAMES = " \
 
 GNOME_APPS = " \
 #  gnome-mplayer \
-#  gcalctool \ 
+  gcalctool \ 
   gnome-keyring gnome-keyring-pam-plugin \
   gksu \
 "
 
-GNOME_GTK = " \
-#  gnome-icon-theme \
-#  angstrom-gnome-icon-theme-enable \
-"
-
 GSTREAMER = " \
 #  gstreamer-ti \
   gst-ffmpeg \
@@ -97,17 +99,21 @@ ICON_THEME = " \
 LAUNCHERS = " \
 #  netbook-launcher-efl \
   pandora-libpnd-minimenu \
-  pandora-pmenu \
+#  pandora-pmenu \
 "
 
 PANDORA = " \
   pandora-first-run-wizard hsetroot \
   pandora-scripts \
-  pandora-wallpaper-official pandora-wallpaper-community \
+  pandora-scripts-wifi \
+  pandora-wallpaper-official \
   pandora-xfce-defaults \
-  pandora-midori-defaults midori \
+#  pandora-midori-defaults midori \
   libgles2d \
   pandora-misc \
+  pandora-pndstore \
+  pandora-configtray \
+  pandora-configtray-wifi \
 "
 
 PERL = " \
@@ -126,24 +132,46 @@ PULSEAUDIO = " \
 #  libasound-module-pcm-pulse \
 "
 
-QT_SELECTED = " qt4-x11-free \
+PYTHON_LIBS = " \
+  python-shell \
+  python-pygtk \
+  python-pycairo \
+  gnome-vfs-plugin-http \
+  gnome-vfs-plugin-ftp \
 "
-# qt4-x11-free"
-# qt4-x11-free-gles"
-
-#PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
 
 QT_SUPPORT = " \
-  ${QT_SELECTED} \
-  qt4-plugin-imageformat-jpeg \
-  qt4-plugin-imageformat-gif \
+ libqt3support4 \ 
+ libqtassistantclient4 \ 
+ libqtclucene4 \ 
+ libqtcore4 \ 
+ libqtdbus4 \ 
+ libqtdesigner4 \ 
+ libqtdesignercomponents4 \ 
+ libqtgui4 \ 
+ libqthelp4 \ 
+ libqtnetwork4 \  
+ libqtscript4 \ 
+ libqtscripttools4 \ 
+ libqtsql4 \ 
+ libqtsvg4 \ 
+ libqttest4 \ 
+ libqtwebkit4 \ 
+ libqtxml4 \  
+ qt4-tools \ 
+ qt4-assistant \ 
+ qt4-common \ 
+ qt4-dbus \ 
+ qt4-designer \ 
+ qt4-fonts \ 
+ qt4-linguist \ 
+ qt4-mkspecs \ 
+ qt4-pixeltool \ 
+ qt4-qt3to4 \
+ qt4-plugin-imageformat-jpeg \
+ qt4-plugin-imageformat-gif \
 "
 
-# We want all of the Qt metapackage (for dev use) without the demos/examples.
-BAD_RRECOMMENDS += " \
-  ${QT_SELECTED}-demos \
-  ${QT_SELECTED}-examples \
-"
 
 TOTEM = " \
 #  totem \
@@ -159,7 +187,7 @@ TOTEM = " \
 "
 
 TOUCHSCREEN = " \
-  gtk-touchscreen-mode-enable \
+#  gtk-touchscreen-mode-enable \
   libgtkstylus \
 #  xinput-calibrator \
 "
@@ -203,6 +231,7 @@ XFCE46_EXTRAS = " \
   ristretto \
   mousepad \ 
   gigolo \
+  xdotool \
 "
 
 XFCE_THEMES = " \
@@ -236,6 +265,37 @@ XSERVER_BASE = " \
   xmodmap \
 "
 
+ADD_LIBS = " \
+  libbonobo \
+  libetpan \
+  libfribidi \
+  libgsf \
+  libidn \
+  libxslt \
+  wv \
+  libsamplerate0 \
+  glibc-gconv-cp1252 \
+  glibc-gconv-ibm850 \
+  glibc-gconv-iso8859-15 \
+  glibc-gconv-cp1250 \
+  glibc-gconv-koi8-r \
+  glibc-gconv-unicode \
+  glibc-gconv-utf-16 \
+  gvfsd-sftp \
+  sshfs-fuse \
+  directfb \
+  rtl8712-module \
+  rtl8192u-module \
+" 
+
+DSP = " \
+  ti-dsplink-module \
+  ti-cmem-module \
+  ti-lpm-module \
+  ti-sdma-module \
+  ti-codecs-omap3530-server \
+"
+
 RDEPENDS_${PN} = " \
   task-pandora-core \
   angstrom-x11-base-depends \
@@ -246,7 +306,6 @@ RDEPENDS_${PN} = " \
   ${DISPMAN} \
   ${FONTS} \
   ${GAMES} \  
-  ${GNOME_GTK} \
   ${GNOME_APPS} \
   ${GSTREAMER} \
   ${ICON_THEME} \
@@ -254,6 +313,7 @@ RDEPENDS_${PN} = " \
   ${PANDORA} \
   ${PERL} \
   ${PULSEAUDIO} \
+  ${PYTHON_LIBS} \
   ${QT_SUPPORT} \
   ${TOTEM} \
   ${TOUCHSCREEN} \
@@ -261,6 +321,8 @@ RDEPENDS_${PN} = " \
   ${XFCE46_BASE} \
   ${XFCE46_EXTRAS} \
   ${XFCE_THEMES} \
+  ${ADD_LIBS} \
+  ${DSP} \
   \
   rxvt-unicode \
 #  xst \
@@ -274,5 +336,6 @@ RDEPENDS_${PN} = " \
   xcursor-transparent-theme \  
   xterm \
   jaaa nmap iperf \
+  xf86-video-udlfb \
 #  gnuplot \
 "