task-pandora-xfce-jap.bb: Fixed configtray-recipe
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index a61bfa7..632b75b 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r55"
+PR = "r72"
 
 inherit task
 
@@ -17,11 +17,16 @@ APPS = " \
 #  gnumeric \   
   networkmanager network-manager-applet \ 
   vnc x11vnc angstrom-x11vnc-xinit \
+  openvpn networkmanager-openvpn \
+  modemmanager \
   xchat \
   links-x11 \
   enchant \
   aspell \
   xwininfo \
+  curl \
+  dosfstools \
+  netkit-ftp \
 #  xournal \
 #  arora \
 "
@@ -100,12 +105,15 @@ LAUNCHERS = " \
 PANDORA = " \
   pandora-first-run-wizard hsetroot \
   pandora-scripts \
+  pandora-scripts-wifi \
   pandora-wallpaper-official \
   pandora-xfce-defaults \
 #  pandora-midori-defaults midori \
   libgles2d \
   pandora-misc \
   pandora-pndstore \
+  pandora-configtray \
+  pandora-configtray-wifi \
 "
 
 PERL = " \
@@ -148,10 +156,8 @@ QT_SUPPORT = " \
  libqtsql4 \ 
  libqtsvg4 \ 
  libqttest4 \ 
- libqtuitools4 \ 
  libqtwebkit4 \ 
- libqtxml4 \ 
- libphonon4 \ 
+ libqtxml4 \  
  qt4-tools \ 
  qt4-assistant \ 
  qt4-common \ 
@@ -181,7 +187,7 @@ TOTEM = " \
 "
 
 TOUCHSCREEN = " \
-  gtk-touchscreen-mode-enable \
+#  gtk-touchscreen-mode-enable \
   libgtkstylus \
 #  xinput-calibrator \
 "
@@ -271,9 +277,25 @@ ADD_LIBS = " \
   glibc-gconv-cp1252 \
   glibc-gconv-ibm850 \
   glibc-gconv-iso8859-15 \
-  
+  glibc-gconv-cp1250 \
+  glibc-gconv-koi8-r \
+  glibc-gconv-unicode \
+  glibc-gconv-utf-16 \
+  gvfsd-sftp \
+  sshfs-fuse \
+  directfb \
+  rtl8712-module \
+  rtl8192u-module \
 " 
 
+DSP = " \
+  ti-dsplink-module \
+  ti-cmem-module \
+  ti-lpm-module \
+  ti-sdma-module \
+  ti-codecs-omap3530-server \
+"
+
 RDEPENDS_${PN} = " \
   task-pandora-core \
   angstrom-x11-base-depends \
@@ -300,6 +322,7 @@ RDEPENDS_${PN} = " \
   ${XFCE46_EXTRAS} \
   ${XFCE_THEMES} \
   ${ADD_LIBS} \
+  ${DSP} \
   \
   rxvt-unicode \
 #  xst \
@@ -313,5 +336,6 @@ RDEPENDS_${PN} = " \
   xcursor-transparent-theme \  
   xterm \
   jaaa nmap iperf \
+  xf86-video-udlfb \
 #  gnuplot \
 "