task-pandora-xfce: Removed Midori and Links, added Links2
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index 3f685e7..193e5f8 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r38"
+PR = "r51"
 
 inherit task
 
@@ -15,11 +15,12 @@ APPS = " \
 #  claws-mail \
   swfdec swfdec-gnome swfdec-mozilla \
 #  gnumeric \   
-  networkmanager network-manager-applet \ 
+  networkmanager network-manager-applet netm-cli 
   vnc x11vnc angstrom-x11vnc-xinit \
   xchat \
+  links-x11 \
 #  xournal \
-  arora \
+#  arora \
 "
 
 BLUETOOTH_GUI = " \
@@ -90,15 +91,15 @@ ICON_THEME = " \
 LAUNCHERS = " \
 #  netbook-launcher-efl \
   pandora-libpnd-minimenu \
-  pandora-pmenu \
+#  pandora-pmenu \
 "
 
 PANDORA = " \
   pandora-first-run-wizard hsetroot \
   pandora-scripts \
-  pandora-wallpaper-official pandora-wallpaper-community \
+  pandora-wallpaper-official \
   pandora-xfce-defaults \
-  pandora-midori-defaults midori \
+#  pandora-midori-defaults midori \
   libgles2d \
   pandora-misc \
 "
@@ -141,7 +142,7 @@ QT_SUPPORT = " \
 "
 
 # We want all of the Qt metapackage (for dev use) without the demos/examples.
-BAD_RRECOMMENDS += " \
+BAD_RECOMMENDATIONS += " \
   ${QT_SELECTED}-demos \
   ${QT_SELECTED}-examples \
 "
@@ -204,6 +205,7 @@ XFCE46_EXTRAS = " \
   ristretto \
   mousepad \ 
   gigolo \
+  xdotool \
 "
 
 XFCE_THEMES = " \
@@ -237,6 +239,20 @@ XSERVER_BASE = " \
   xmodmap \
 "
 
+ADD_LIBS = " \
+  libbonobo \
+  libetpan \
+  libfribidi \
+  libgsf \
+  libidn \
+  wv \
+  libsamplerate0 \
+  glibc-gconv-cp1252 \
+  glibc-gconv-ibm850 \
+  glibc-gconv-iso8859-15 \
+  
+" 
+
 RDEPENDS_${PN} = " \
   task-pandora-core \
   angstrom-x11-base-depends \
@@ -262,6 +278,7 @@ RDEPENDS_${PN} = " \
   ${XFCE46_BASE} \
   ${XFCE46_EXTRAS} \
   ${XFCE_THEMES} \
+  ${ADD_LIBS} \
   \
   rxvt-unicode \
 #  xst \