New PND: op_ledsettings.pnd
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index 951def4..013187b 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r59"
+PR = "r71"
 
 inherit task
 
@@ -17,6 +17,8 @@ APPS = " \
 #  gnumeric \   
   networkmanager network-manager-applet \ 
   vnc x11vnc angstrom-x11vnc-xinit \
+  openvpn networkmanager-openvpn \
+  modemmanager \
   xchat \
   links-x11 \
   enchant \
@@ -24,6 +26,7 @@ APPS = " \
   xwininfo \
   curl \
   dosfstools \
+  netkit-ftp \
 #  xournal \
 #  arora \
 "
@@ -108,6 +111,7 @@ PANDORA = " \
   libgles2d \
   pandora-misc \
   pandora-pndstore \
+  pandora-configtray \
 "
 
 PERL = " \
@@ -181,7 +185,7 @@ TOTEM = " \
 "
 
 TOUCHSCREEN = " \
-  gtk-touchscreen-mode-enable \
+#  gtk-touchscreen-mode-enable \
   libgtkstylus \
 #  xinput-calibrator \
 "
@@ -226,7 +230,6 @@ XFCE46_EXTRAS = " \
   mousepad \ 
   gigolo \
   xdotool \
-  openbox \
 "
 
 XFCE_THEMES = " \
@@ -272,10 +275,25 @@ ADD_LIBS = " \
   glibc-gconv-cp1252 \
   glibc-gconv-ibm850 \
   glibc-gconv-iso8859-15 \
+  glibc-gconv-cp1250 \
+  glibc-gconv-koi8-r \
+  glibc-gconv-unicode \
+  glibc-gconv-utf-16 \
   gvfsd-sftp \
   sshfs-fuse \
+  directfb \
+  rtl8712-module \
+  rtl8192u-module \
 " 
 
+DSP = " \
+  ti-dsplink-module \
+  ti-cmem-module \
+  ti-lpm-module \
+  ti-sdma-module \
+  ti-codecs-omap3530-server \
+"
+
 RDEPENDS_${PN} = " \
   task-pandora-core \
   angstrom-x11-base-depends \
@@ -302,6 +320,7 @@ RDEPENDS_${PN} = " \
   ${XFCE46_EXTRAS} \
   ${XFCE_THEMES} \
   ${ADD_LIBS} \
+  ${DSP} \
   \
   rxvt-unicode \
 #  xst \
@@ -315,5 +334,6 @@ RDEPENDS_${PN} = " \
   xcursor-transparent-theme \  
   xterm \
   jaaa nmap iperf \
+  xf86-video-udlfb \
 #  gnuplot \
 "