op_datetime.sh: Fixed screen blanking when changing time
[openpandora.oe.git] / recipes / tasks / task-pandora-gui.bb
index 28803c0..10a03c2 100755 (executable)
-DESCRIPTION = "Task file for default GUI apps in the Pandora image"
+rDESCRIPTION = "Task file for default GUI apps in the Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r0.1"
+PR = "r1"
 
 inherit task
 
-RDEPENDS_${PN} = "\
-        task-pandora-core \
+ANGSTROM_EXTRA_INSTALL ?= ""
+
+APPS = " \
+  abiword \
+  cheese \
+  claws-mail \
+  epiphany epiphany-extensions \
+  swfdec swfdec-gnome swfdec-mozilla \
+  evince \
+  gcalctool \
+  gedit \
+  gimp \
+  gnome-games \
+  gnome-mplayer \
+  gnumeric \
+  gphoto2 \
+  gthumb \
+  pidgin \
+  synergy \
+  vnc \
+  x11vnc angstrom-x11vnc-xinit \
+  xmms \
+  xterm \
+"
+
+FONTS = " \
+  font-adobe-75dpi \
+  fontconfig fontconfig-utils font-util \
+  ttf-arphic-uming \
+  ttf-dejavu-common \
+  ttf-dejavu-sans \
+  ttf-dejavu-serif \
+  ttf-dejavu-sans-mono \
+  ttf-liberation-sans \
+  ttf-liberation-serif \
+  ttf-liberation-mono \
+  xorg-minimal-fonts \
+"  
+
+GSTREAMER = " \
+  gst-ffmpeg \
+  gst-omapfb \
+  gst-plugin-pulse \
+  gst-plugins-base-meta \
+  gst-plugins-good-meta \
+  gst-plugins-bad-meta \
+#  gst-plugins-ugly-meta \
+"
+
+PERL = " \
+  perl \
+#  task-perl-module-all \
+#  libnet-dbus-perl \
+  libxml-parser-perl \
+  libxml-twig-perl \
+"
+
+PULSEAUDIO = " \
+  pulseaudio-alsa-wrapper \
+  pulseaudio-esd-wrapper \
+  pulseaudio-module-gconf \
+  libasound-module-ctl-pulse \
+  libasound-module-pcm-pulse \
+"
+
+XSERVER_BASE = " \
+  ${XSERVER} \
+  dbus-x11 \
+  desktop-file-utils \
+  iso-codes \
+  mime-support \
+  notification-daemon inotify-tools \
+  xauth \
+#  xdg-utils \
+  xhost \
+  xinetd \
+  xinit \
+  xlsfonts \
+  xrdb \
+  xrefresh \
+  xset \
+  xvinfo \
+"
+
+RDEPENDS_${PN} = " \
+  task-pandora-core \
+  ${ANGSTROM_EXTRA_INSTALL} \
+  ${APPS} \
+  ${FONTS} \
+  ${GSTREAMER} \
+  ${PERL} \
+  ${PULSEAUDIO} \
+  ${XSERVER_BASE} \
         angstrom-x11-base-depends \
         angstrom-gpe-task-base angstrom-gpe-task-game angstrom-gpe-task-apps angstrom-gpe-task-settings \
         angstrom-zeroconf-audio \
@@ -20,7 +111,6 @@ RDEPENDS_${PN} = "\
         abiword \
         claws-mail \
         evince \
-        exhibit \
         pidgin \
         gnome-games \
         synergy \
@@ -28,10 +118,7 @@ RDEPENDS_${PN} = "\
         xmms \
         xterm \
         xtscal \
-        matchbox-wm \
-        matchbox-desktop matchbox-panel matchbox-panel-manager matchbox-panel-hacks \
-        matchbox-keyboard matchbox-keyboard-applet matchbox-keyboard-im \
-        matchbox-common matchbox-config-gtk \
+        matchbox2 \
         matchbox-terminal \
         matchbox-themes-gtk pandora-matchbox-gtk-theme \
         pcmanfm \
@@ -43,6 +130,8 @@ RDEPENDS_${PN} = "\
         matchbox-applet-inputmanager \
         matchbox-applet-volume \
         matchbox-applet-startup-monitor \
-       connman-gnome \
+#      connman-gnome \
+       networkmanager \
         scummvm \
+       gnome-bluetooth \
 "