pandora-scripts.bb: Fixed missing tvout-profiles.conf
[openpandora.oe.git] / recipes / tasks / task-pandora-desktop.bb
index 9ecb69f..b940f58 100755 (executable)
@@ -2,38 +2,131 @@ DESCRIPTION = "Task file for the 'desktop' Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r1.10"
+PR = "r1"
 
 inherit task
 
-ECONFIG ?= "places e-wm-config-angstrom e-wm-config-default"
+ANGSTROM_EXTRA_INSTALL ?= ""
 
-RDEPENDS_${PN} = "\
-       task-pandora-core \
-       entrance \
+APPS = " \
+  abiword \
+  cheese \
+  claws-mail \
+  epiphany epiphany-extensions \
+  swfdec swfdec-gnome swfdec-mozilla \
+  evince \
+  gcalctool \
+  gedit \
+  gimp \
+  gnome-games \
+  gnome-mplayer \
+  gnumeric \
+  gphoto2 \
+  gthumb \
+  pidgin \
+  synergy \
+  vnc \
+  x11vnc angstrom-x11vnc-xinit \
+  xmms \
+  xterm \
+"
+
+E17 = " \
+  e-wm \
+  places \
+  e-wm-config-angstrom e-wm-config-angstrom-touchscreen e-wm-config-angstrom-widescreen e-wm-config-default \
+"
+
+FONTS = " \
+  font-adobe-75dpi \
+  fontconfig fontconfig-utils font-util \
+  ttf-arphic-uming \
+  ttf-dejavu-common \
+  ttf-dejavu-sans \
+  ttf-dejavu-serif \
+  ttf-dejavu-sans-mono \
+  ttf-liberation-sans \
+  ttf-liberation-serif \
+  ttf-liberation-mono \
+  xorg-minimal-fonts \
+"  
+
+GSTREAMER = " \
+  gst-ffmpeg \
+  gst-omapfb \
+  gst-plugin-pulse \
+  gst-plugins-base-meta \
+  gst-plugins-good-meta \
+  gst-plugins-bad-meta \
+#  gst-plugins-ugly-meta \
+"
+
+PERL = " \
+  perl \
+#  task-perl-module-all \
+#  libnet-dbus-perl \
+  libxml-parser-perl \
+  libxml-twig-perl \
+"
+
+PULSEAUDIO = " \
+  pulseaudio-alsa-wrapper \
+  pulseaudio-esd-wrapper \
+  pulseaudio-module-gconf \
+  libasound-module-ctl-pulse \
+  libasound-module-pcm-pulse \
+"
+
+XSERVER_BASE = " \
+  ${XSERVER} \
+  dbus-x11 \
+  desktop-file-utils \
+  iso-codes \
+  mime-support \
+  notification-daemon inotify-tools \
+  xauth \
+#  xdg-utils \
+  xhost \
+  xinetd \
+  xinit \
+  xlsfonts \
+  xrdb \
+  xrefresh \
+  xset \
+  xvinfo \
+"
+
+RDEPENDS_${PN} = " \
+  task-pandora-core \
+  ${ANGSTROM_EXTRA_INSTALL} \
+  ${APPS} \
+  ${E17} \
+  ${FONTS} \
+  ${GSTREAMER} \
+  ${PERL} \
+  ${PULSEAUDIO} \
+  ${XSERVER_BASE} \
        angstrom-x11-base-depends \
-        angstrom-gpe-task-base angstrom-gpe-task-game angstrom-ohand-task-pim angstrom-gpe-task-apps angstrom-gpe-task-settings \
+       angstrom-gpe-task-base angstrom-gpe-task-settings \
        angstrom-zeroconf-audio \
        angstrom-led-config \ 
        gpe-scap \
-       mime-support e-wm ${ECONFIG} exhibit \
+       mime-support \
        xterm xmms \
        firefox midori \
-       swfdec-mozilla \
+       gecko-mediaplayer-firefox-hack \
        hicolor-icon-theme gnome-icon-theme \
        jaaa nmap iperf gnuplot \
        abiword \
        gnumeric \
        gimp \
-       oprofile \
        pidgin \
        gnome-games \
        stalonetray \
        synergy \
        x11vnc angstrom-x11vnc-xinit \
        angstrom-gnome-icon-theme-enable \
-#      networkmanager-applet \
-       connman-gnome \
-       scummvm \
-       ogre-egl \
+#      connman-gnome \
+       networkmanager network-manager-applet \
+       gnome-bluetooth \
 "