Merge branch 'master' of git://git.openpandora.org/openpandora.oe
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
index 1a2ae44..f24a7b1 100755 (executable)
@@ -5,7 +5,7 @@ DESCRIPTION = "Task file for default core/console apps and libs in the Pandora i
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r30"
+PR = "r34"
 
 inherit task 
 
@@ -28,7 +28,7 @@ BOOT = " \
 
 # Package BOOST libs so people can use them in apps. It will pull in the RRECOMENDS.
 BOOST = " \
-  boost-14x \
+  boost \
 "
 
 WIRELESS = " \
@@ -48,12 +48,13 @@ MEDIA_LIBS = " \
   faad2 \
   mikmod \
   speex \  
-  flac \  
+  flac \
+  audiofile \
 "
 OPENGLES = " \
   omap3-sgx-modules devmem2 \
   libgles-omap3 \
-  libgles-omap3-rawdemos \
+#  libgles-omap3-rawdemos \
 "
 
 PAM = " \
@@ -98,6 +99,9 @@ EXTRA_TOOLS = " \
   file \
   socat \
   strace \
+  screen \
+  rsync \
+  unrar \
   ksymoops \
   kexec-tools \
   zip \        
@@ -109,6 +113,7 @@ EXTRA_TOOLS = " \
   gdb \
   sessreg \
   lua5.1 \
+  tzdata \
 "
 
 # Add extra util-linux-ng utils to image. 
@@ -138,6 +143,8 @@ RDEPENDS_${PN} = "\
   ${UTIL_LINUX_NG_EXTRAS} \
 #        packagekit \
   python-pygame \
+  python-misc \
+  python-modules \
   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
   rdesktop \
   \