pandora-version: bump for util-linux-ng
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
index bc86a7a..7f1dac1 100755 (executable)
@@ -5,12 +5,11 @@ DESCRIPTION = "Task file for default core/console apps and libs in the Pandora i
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r20"
+PR = "r46"
 
 inherit task 
 
 AUFS = " \
-#  aufs2-27 \
   aufs2-util \
 "
 
@@ -24,11 +23,17 @@ BLUETOOTH = " \
 BOOT = " \
   pandora-uboot-scripts \
   bootchart \
+  mtd-utils \
+"
+
+# Package BOOST libs so people can use them in apps. It will pull in the RRECOMENDS.
+BOOST = " \
+  boost \
 "
 
 WIRELESS = " \
-  pandora-firmware \
-  wl1251-modules \
+#  pandora-firmware \
+#  wl1251-modules \
 #  pandora-wifi pandora-wifi-tools \
   wireless-tools \
   wpa-supplicant \  
@@ -43,12 +48,14 @@ MEDIA_LIBS = " \
   faad2 \
   mikmod \
   speex \  
-  
+  flac \
+  audiofile \
 "
 OPENGLES = " \
   omap3-sgx-modules devmem2 \
-  libgles-omap3 \
-  libgles-omap3-rawdemos \
+  libgles-omap3-es23 \
+  libgles-omap3-dm3730 \
+#  libgles-omap3-rawdemos \
 "
 
 PAM = " \
@@ -57,9 +64,13 @@ PAM = " \
 "
 
 PANDORA_LIBS = " \
-  pandora-libpnd lsof \
+  pandora-libpnd \
+  pandora-libpnd-pndnotifyd pandora-libpnd-pndevmapperd \
+  lsof \
   omap3-deviceid \
   pandora-skel \
+  pandora-state \
+  pandora-usbhost \
 "
 
 SUDO = " \
@@ -92,6 +103,9 @@ EXTRA_TOOLS = " \
   file \
   socat \
   strace \
+  screen \
+  rsync \
+  unrar \
   ksymoops \
   kexec-tools \
   zip \        
@@ -102,25 +116,40 @@ EXTRA_TOOLS = " \
   nano \
   gdb \
   sessreg \
+  lua5.1 \
+  tzdata \
+  ca-certificates \
 "
 
 # Add extra util-linux-ng utils to image. 
 # TODO: Fix util-linux-ng to meta depend on all subpackages.
 UTIL_LINUX_NG_EXTRAS = " \
-  util-linux-ng-losetup util-linux-ng-mountall \
+  util-linux-ng-losetup \
   util-linux-ng-swaponoff \
 "
-  
+
+# sysvinit-* used to not be needed, but after adding
+# recipes/sysvinit/sysvinit/omap3-pandora/*
+# they are no longer included automatically?
+SYSVINIT = " \
+  sysvinit-inittab \
+  sysvinit-sulogin \
+  sysvinit-utils \
+"
+
 RDEPENDS_${PN} = "\
   task-base-extended \
   task-proper-tools \
+  ${SYSVINIT} \
   ${AUFS} \
+  ${BOOST} \
   ${WIRELESS} \
   ${BLUETOOTH} \  
   ${BOOT} \
   ${MEDIA_LIBS} \
   ${OPENGLES} \
   ${PANDORA_LIBS} \
+  ${PAM} \  
   ${SSH} \
   ${SUDO} \
   ${TOUCHSCREEN} \
@@ -129,22 +158,19 @@ RDEPENDS_${PN} = "\
   ${UTIL_LINUX_NG_EXTRAS} \
 #        packagekit \
   python-pygame \
+  python-misc \
+  python-modules \
   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
+  openal-soft \
   rdesktop \
-  mplayer \
   \
 #  angstrom-zeroconf-audio \
   angstrom-led-config \ 
-  \
-  ${PAM} \
+  ntpdate \ 
+  omap3-pandora-kernel2 \
 "
 
 # Make sure we install all kernel modules with the Pandora images
 RRECOMMENDS_${PN} += "kernel-modules"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-RRECOMMENDS_${PN}_append_armv7a = " \
-#      gnash gnash-browser-plugin \
-       omapfbplay \
-"