pandora-version: bump for util-linux-ng
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
index 5927f8b..7f1dac1 100755 (executable)
@@ -5,7 +5,7 @@ DESCRIPTION = "Task file for default core/console apps and libs in the Pandora i
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r26"
+PR = "r46"
 
 inherit task 
 
@@ -32,8 +32,8 @@ BOOST = " \
 "
 
 WIRELESS = " \
-  pandora-firmware \
-  wl1251-modules \
+#  pandora-firmware \
+#  wl1251-modules \
 #  pandora-wifi pandora-wifi-tools \
   wireless-tools \
   wpa-supplicant \  
@@ -48,12 +48,14 @@ MEDIA_LIBS = " \
   faad2 \
   mikmod \
   speex \  
-  flac \  
+  flac \
+  audiofile \
 "
 OPENGLES = " \
   omap3-sgx-modules devmem2 \
-  libgles-omap3 \
-  libgles-omap3-rawdemos \
+  libgles-omap3-es23 \
+  libgles-omap3-dm3730 \
+#  libgles-omap3-rawdemos \
 "
 
 PAM = " \
@@ -62,10 +64,13 @@ PAM = " \
 "
 
 PANDORA_LIBS = " \
-  pandora-libpnd lsof \
+  pandora-libpnd \
+  pandora-libpnd-pndnotifyd pandora-libpnd-pndevmapperd \
+  lsof \
   omap3-deviceid \
   pandora-skel \
-  pandora-lcd-state \
+  pandora-state \
+  pandora-usbhost \
 "
 
 SUDO = " \
@@ -98,6 +103,9 @@ EXTRA_TOOLS = " \
   file \
   socat \
   strace \
+  screen \
+  rsync \
+  unrar \
   ksymoops \
   kexec-tools \
   zip \        
@@ -109,18 +117,30 @@ EXTRA_TOOLS = " \
   gdb \
   sessreg \
   lua5.1 \
+  tzdata \
+  ca-certificates \
 "
 
 # Add extra util-linux-ng utils to image. 
 # TODO: Fix util-linux-ng to meta depend on all subpackages.
 UTIL_LINUX_NG_EXTRAS = " \
-  util-linux-ng-losetup util-linux-ng-mountall \
+  util-linux-ng-losetup \
   util-linux-ng-swaponoff \
 "
-  
+
+# sysvinit-* used to not be needed, but after adding
+# recipes/sysvinit/sysvinit/omap3-pandora/*
+# they are no longer included automatically?
+SYSVINIT = " \
+  sysvinit-inittab \
+  sysvinit-sulogin \
+  sysvinit-utils \
+"
+
 RDEPENDS_${PN} = "\
   task-base-extended \
   task-proper-tools \
+  ${SYSVINIT} \
   ${AUFS} \
   ${BOOST} \
   ${WIRELESS} \
@@ -138,11 +158,16 @@ RDEPENDS_${PN} = "\
   ${UTIL_LINUX_NG_EXTRAS} \
 #        packagekit \
   python-pygame \
+  python-misc \
+  python-modules \
   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
+  openal-soft \
   rdesktop \
   \
 #  angstrom-zeroconf-audio \
   angstrom-led-config \ 
+  ntpdate \ 
+  omap3-pandora-kernel2 \
 "
 
 # Make sure we install all kernel modules with the Pandora images