pandora-tasks: Rearranged so that opkg shouldn't go crazy.
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
index e17f7fb..7915bfa 100755 (executable)
@@ -5,12 +5,11 @@ DESCRIPTION = "Task file for default core/console apps and libs in the Pandora i
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r18"
+PR = "r40"
 
 inherit task 
 
 AUFS = " \
-#  aufs2-27 \
   aufs2-util \
 "
 
@@ -24,11 +23,17 @@ BLUETOOTH = " \
 BOOT = " \
   pandora-uboot-scripts \
   bootchart \
+  mtd-utils \
+"
+
+# Package BOOST libs so people can use them in apps. It will pull in the RRECOMENDS.
+BOOST = " \
+  boost \
 "
 
 WIRELESS = " \
-  pandora-firmware \
-  wl1251-modules \
+#  pandora-firmware \
+#  wl1251-modules \
 #  pandora-wifi pandora-wifi-tools \
   wireless-tools \
   wpa-supplicant \  
@@ -39,14 +44,17 @@ MEDIA_LIBS = " \
   libmodplug \
   libsdl-x11 libsdl-mixer libsdl-image \
   libsdl-gfx libsdl-net libsdl-ttf \
+  libpng libpng12 libpng3 \
+  faad2 \
   mikmod \
   speex \  
-  
+  flac \
+  audiofile \
 "
 OPENGLES = " \
   omap3-sgx-modules devmem2 \
   libgles-omap3 \
-  libgles-omap3-rawdemos \
+#  libgles-omap3-rawdemos \
 "
 
 PAM = " \
@@ -58,6 +66,8 @@ PANDORA_LIBS = " \
   pandora-libpnd lsof \
   omap3-deviceid \
   pandora-skel \
+  pandora-state \
+  pandora-usbhost \
 "
 
 SUDO = " \
@@ -90,6 +100,9 @@ EXTRA_TOOLS = " \
   file \
   socat \
   strace \
+  screen \
+  rsync \
+  unrar \
   ksymoops \
   kexec-tools \
   zip \        
@@ -100,6 +113,8 @@ EXTRA_TOOLS = " \
   nano \
   gdb \
   sessreg \
+  lua5.1 \
+  tzdata \
 "
 
 # Add extra util-linux-ng utils to image. 
@@ -113,12 +128,14 @@ RDEPENDS_${PN} = "\
   task-base-extended \
   task-proper-tools \
   ${AUFS} \
+  ${BOOST} \
   ${WIRELESS} \
   ${BLUETOOTH} \  
   ${BOOT} \
   ${MEDIA_LIBS} \
   ${OPENGLES} \
   ${PANDORA_LIBS} \
+  ${PAM} \  
   ${SSH} \
   ${SUDO} \
   ${TOUCHSCREEN} \
@@ -127,22 +144,19 @@ RDEPENDS_${PN} = "\
   ${UTIL_LINUX_NG_EXTRAS} \
 #        packagekit \
   python-pygame \
+  python-misc \
+  python-modules \
   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
+  openal-soft \
   rdesktop \
-  mplayer \
   \
 #  angstrom-zeroconf-audio \
   angstrom-led-config \ 
-  \
-  ${PAM} \
+  ntpdate \ 
+  omap3-pandora-kernel2 \
 "
 
 # Make sure we install all kernel modules with the Pandora images
 RRECOMMENDS_${PN} += "kernel-modules"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-RRECOMMENDS_${PN}_append_armv7a = " \
-#      gnash gnash-browser-plugin \
-       omapfbplay \
-"