pandora-tasks: Rearranged so that opkg shouldn't go crazy.
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
index 1a2ae44..7915bfa 100755 (executable)
@@ -5,7 +5,7 @@ DESCRIPTION = "Task file for default core/console apps and libs in the Pandora i
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r30"
+PR = "r40"
 
 inherit task 
 
@@ -28,12 +28,12 @@ BOOT = " \
 
 # Package BOOST libs so people can use them in apps. It will pull in the RRECOMENDS.
 BOOST = " \
-  boost-14x \
+  boost \
 "
 
 WIRELESS = " \
-  pandora-firmware \
-  wl1251-modules \
+#  pandora-firmware \
+#  wl1251-modules \
 #  pandora-wifi pandora-wifi-tools \
   wireless-tools \
   wpa-supplicant \  
@@ -48,12 +48,13 @@ MEDIA_LIBS = " \
   faad2 \
   mikmod \
   speex \  
-  flac \  
+  flac \
+  audiofile \
 "
 OPENGLES = " \
   omap3-sgx-modules devmem2 \
   libgles-omap3 \
-  libgles-omap3-rawdemos \
+#  libgles-omap3-rawdemos \
 "
 
 PAM = " \
@@ -66,6 +67,7 @@ PANDORA_LIBS = " \
   omap3-deviceid \
   pandora-skel \
   pandora-state \
+  pandora-usbhost \
 "
 
 SUDO = " \
@@ -98,6 +100,9 @@ EXTRA_TOOLS = " \
   file \
   socat \
   strace \
+  screen \
+  rsync \
+  unrar \
   ksymoops \
   kexec-tools \
   zip \        
@@ -109,6 +114,7 @@ EXTRA_TOOLS = " \
   gdb \
   sessreg \
   lua5.1 \
+  tzdata \
 "
 
 # Add extra util-linux-ng utils to image. 
@@ -138,11 +144,16 @@ RDEPENDS_${PN} = "\
   ${UTIL_LINUX_NG_EXTRAS} \
 #        packagekit \
   python-pygame \
+  python-misc \
+  python-modules \
   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
+  openal-soft \
   rdesktop \
   \
 #  angstrom-zeroconf-audio \
   angstrom-led-config \ 
+  ntpdate \ 
+  omap3-pandora-kernel2 \
 "
 
 # Make sure we install all kernel modules with the Pandora images