task-pandora-core: bump
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
index 8d2dfe9..0494f6b 100755 (executable)
@@ -5,7 +5,7 @@ DESCRIPTION = "Task file for default core/console apps and libs in the Pandora i
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r24"
+PR = "r41"
 
 inherit task 
 
@@ -26,9 +26,14 @@ BOOT = " \
   mtd-utils \
 "
 
+# Package BOOST libs so people can use them in apps. It will pull in the RRECOMENDS.
+BOOST = " \
+  boost \
+"
+
 WIRELESS = " \
-  pandora-firmware \
-  wl1251-modules \
+#  pandora-firmware \
+#  wl1251-modules \
 #  pandora-wifi pandora-wifi-tools \
   wireless-tools \
   wpa-supplicant \  
@@ -43,12 +48,13 @@ MEDIA_LIBS = " \
   faad2 \
   mikmod \
   speex \  
-  
+  flac \
+  audiofile \
 "
 OPENGLES = " \
   omap3-sgx-modules devmem2 \
   libgles-omap3 \
-  libgles-omap3-rawdemos \
+#  libgles-omap3-rawdemos \
 "
 
 PAM = " \
@@ -60,7 +66,8 @@ PANDORA_LIBS = " \
   pandora-libpnd lsof \
   omap3-deviceid \
   pandora-skel \
-  pandora-lcd-state \
+  pandora-state \
+  pandora-usbhost \
 "
 
 SUDO = " \
@@ -93,6 +100,9 @@ EXTRA_TOOLS = " \
   file \
   socat \
   strace \
+  screen \
+  rsync \
+  unrar \
   ksymoops \
   kexec-tools \
   zip \        
@@ -103,6 +113,8 @@ EXTRA_TOOLS = " \
   nano \
   gdb \
   sessreg \
+  lua5.1 \
+  tzdata \
 "
 
 # Add extra util-linux-ng utils to image. 
@@ -116,6 +128,7 @@ RDEPENDS_${PN} = "\
   task-base-extended \
   task-proper-tools \
   ${AUFS} \
+  ${BOOST} \
   ${WIRELESS} \
   ${BLUETOOTH} \  
   ${BOOT} \
@@ -131,11 +144,16 @@ RDEPENDS_${PN} = "\
   ${UTIL_LINUX_NG_EXTRAS} \
 #        packagekit \
   python-pygame \
+  python-misc \
+  python-modules \
   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
+  openal-soft \
   rdesktop \
   \
 #  angstrom-zeroconf-audio \
   angstrom-led-config \ 
+  ntpdate \ 
+  omap3-pandora-kernel2 \
 "
 
 # Make sure we install all kernel modules with the Pandora images