Update tree with local changes. Disable WiLink4 drivers in the image and enable the...
[openpandora.oe.git] / recipes / pandora-system / pandora-wifi_git.bb
index cf97a6b..4640f76 100755 (executable)
@@ -1,14 +1,16 @@
 DESCRIPTION = "Kernel drivers for the TI1251 WiFi chip found on the Pandora - Connected via SDIO"
 LICENSE = "GPLv2"
 
-PR = "r9.2"
-
 # Check the include for the source location/GIT SRCREV etc.
 require pandora-wifi.inc
 
 SRC_URI += " \
        file://rc.tiwifi \
-#      file://0011-Add-in-the-start-of-wireless-extensions-support-ioc.patch;patch=1 \
+       file://0001-Initial-work-on-WEXT-support.patch;patch=1 \
+       file://0002-More-cleanup-work-on-WEXT.-Now-at-the-point-that-use.patch;patch=1 \
+       file://0003-Oooops-now-lets-try-something-that-compiles.patch;patch=1 \
+       file://0004-Clean-up-to-use-IW_RETRY_LONG-and-IW_RETRY_SHORT.patch;patch=1 \
+       file://0005-Fix-ooops-I-really-don-t-want-funky-private-features.patch;patch=1 \
 "
 
 inherit update-rc.d
@@ -29,4 +31,4 @@ do_install() {
           cp -pP ${S}/sta_dk_4_0_4_32/fw/tiwlan.ini ${D}${sysconfdir}/tiwlan.ini         
 }
 
-FILES_${PN} += "/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless/tiwlan/*.ko.*"
\ No newline at end of file
+FILES_${PN} += "/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless/tiwlan/*.ko.*"