pandora-wifi: Removed wl1251-init from autostartup as default.
[openpandora.oe.git] / recipes / pandora-system / pandora-wifi_git.bb
index cf97a6b..33c99e1 100755 (executable)
@@ -1,20 +1,30 @@
 DESCRIPTION = "Kernel drivers for the TI1251 WiFi chip found on the Pandora - Connected via SDIO"
 LICENSE = "GPLv2"
 
 DESCRIPTION = "Kernel drivers for the TI1251 WiFi chip found on the Pandora - Connected via SDIO"
 LICENSE = "GPLv2"
 
-PR = "r9.2"
-
 # Check the include for the source location/GIT SRCREV etc.
 require pandora-wifi.inc
 
 SRC_URI += " \
        file://rc.tiwifi \
 # Check the include for the source location/GIT SRCREV etc.
 require pandora-wifi.inc
 
 SRC_URI += " \
        file://rc.tiwifi \
-#      file://0011-Add-in-the-start-of-wireless-extensions-support-ioc.patch;patch=1 \
+#      file://0001-Initial-work-on-WEXT-support.patch;patch=1 \
+#      file://0002-More-cleanup-work-on-WEXT.-Now-at-the-point-that-use.patch;patch=1 \
+#      file://0003-Oooops-now-lets-try-something-that-compiles.patch;patch=1 \
+#      file://0004-Clean-up-to-use-IW_RETRY_LONG-and-IW_RETRY_SHORT.patch;patch=1 \
+#      file://0005-Fix-ooops-I-really-don-t-want-funky-private-features.patch;patch=1 \
+       file://0001-Fix-in-wlan_cu-makefile-to-make-OUTPUT_DIR-not-fixed.patch;patch=1 \
+       file://0002-Add-in-the-start-of-wireless-extensions-support-ioct.patch;patch=1 \
+       file://0003-Merge-in-latest-wireless-ext.-hacks.patch;patch=1 \
+       file://0004-Default-to-DEBUG-Y-for-testing.patch;patch=1 \
+       file://0005-More-WEXT-cleanup.patch;patch=1 \   
+       file://0006-Add-back-in-missing-header-o.patch;patch=1 \
+       file://0007-Add-iw_ioctl.h-header.patch;patch=1 \
+       file://0008-Update-Wireless-EXT-with-test-code.patch;patch=1 \
 "
 
 inherit update-rc.d
 
 INITSCRIPT_NAME = "tiwifi-init"
 "
 
 inherit update-rc.d
 
 INITSCRIPT_NAME = "tiwifi-init"
-INITSCRIPT_PARAMS = "start 30 5 2 . stop 40 0 1 6 ."
+INITSCRIPT_PARAMS = "stop 40 0 1 6 ."
 
 do_compile_prepend() {
           cd ${S}/sta_dk_4_0_4_32/
 
 do_compile_prepend() {
           cd ${S}/sta_dk_4_0_4_32/
@@ -29,4 +39,4 @@ do_install() {
           cp -pP ${S}/sta_dk_4_0_4_32/fw/tiwlan.ini ${D}${sysconfdir}/tiwlan.ini         
 }
 
           cp -pP ${S}/sta_dk_4_0_4_32/fw/tiwlan.ini ${D}${sysconfdir}/tiwlan.ini         
 }
 
-FILES_${PN} += "/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless/tiwlan/*.ko.*"
\ No newline at end of file
+FILES_${PN} += "/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless/tiwlan/*.ko.*"